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1.0 Installation

Touch Assist II is supplied on a single floppy disk and is comprised of

three files:

1) TOUCH.EXE

2) TOUCH.HLP

3) TOUCH.INI

To install Touch Assist II, copy the files TOUCH.EXE and

TOUCH.HLP into the same directory. This may be any directory

(e.g. C:\TAII). The file TOUCH.INI should be copied into the

directory where Windows is installed (e.g. C:\WINDOWS).

2.0 Overview

Touch Assist II (TAII) is the second generation of Lucas Control

Systems Products� application generating tool for its touch/graphic

products. These products are intelligent flat panel controllers married

with infrared touch sensing arrays. TAII allows users to generate

graphic screen images and construct touch menu systems for use in

LCSP products.

TAII is intended to aid the application and OEM designer in

incorporating LCSP products into their systems. It provides an easy-

to-use graphical interface to the features and functions of the LCSP

product family. It is a screen generator, CAD tool, and paint program

whose output is easily incorporated into software systems, or

embedded within the LCSP product.

2.1 LCSP Touch/Graphic Products

LCSP products are intelligent controllers for flat panel touch systems.

The system of flat panel, infrared touch, and controller is designed as

a stand-alone ASCII/graphics terminal.
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2.2 Text and Graphics Capability

The terminal functionality is based on Digital Equipment

Corporation's popular VT series (VT100, VT220, VT320, etc.). The

VT series is the originator and prime user of the ANSI 3.64 standard

command language for text terminals. The text terminal emulation is

accurate and reliable for these products. Some offer more complete

emulations but all offer accuracy in the subset of the VTxxx

commands that they support. They support multiple visual pages,

multiple character sets, user-definable characters, editing functions,

and extensive cursor control.

The graphics functions in LCSP products are accessed through an

extension of the VTxxx command structure. Basic graphic objects

such as vector, circle, arc, and graphic text are supported as well as

advanced functions controlling coordinate transformation, clipping,

and windowing.

2.3 Touch Capability

The touch system, offered on all LCSP products, extends the terminal

functionality and creates a simple, powerful man-machine interface.

Touch input can be as simple as X, Y coordinate pair reporting. When

the user touches the screen, the coordinates describing the position of

the touch are reported to the host over the communication link. LCSP

products offer this and more. The interface designer may define

regions on the screen which represent actuators (buttons). When a

button is touched, the terminal may be programmed to take action

independent of the host. That is, the designer may embed commands

in the definition of the button freeing the host of wasteful overhead.
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2.3.1 Buttons and Menus

The "button" is the basic touch unit in the intelligent touch system. A

button is defined by its position and size on the screen, its visual

appearance, and its response. Many buttons may be grouped together

to form a page (menu).

The button response, which is activated by touching the button, is

divided into two parts, the local response and the host message. The

host message is an ASCII string which is sent to the host over the

communication link. The local response is an ASCII string which is

treated like a host command stream: it may contain any command

which the host itself could send to the terminal. It is the local response

which represents the embedded intelligence of the touch system.

A menu, or page, is a group of buttons. A menu may be identified by

a single number (the page number). When activated by a command, a

menu is automatically drawn on the screen. Menus may be linked in a

hierarchical structure by embedding the command to activate another

menu in the local response of a button on the currently active menu.

3.0 Touch Assist II Design Tools

TAII is a Microsoft Windows 3.1 compatible application. Much of

the "look and feel" of TAII is standard Windows giving the designer a

head start in understanding how it works. Some Windows techniques

used in TAII and described in this manual such as "clicking", "double

clicking", and "dragging" are essential in the use and understanding of

TAII. Descriptions of these techniques and others may be found in the

Windows manual.
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TAII offers the interface designer a variety of tools to build the visual and

tactile interface. The designer may build button menus, link them, and

design associated graphic images. TAII uses palettes of design tools, on-line

help, and download functions to aid the design process. The final output of

TAII can be transferred directly to a LCSP device or the output can be

incorporated into the program of the host system either as a data file or as

compiled C code.

The TAII is composed primarily of four tool types:

1) System configuration and control

2) Target configuration and control

3) Graphics generation

4) Touch menu generation.

The access to these tools is from the main menu bar, the function

palette, and the graphics palette.
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The TAII layout consists of the following major components on the PC

monitor:

Title Bar a standard Windows item that displays the file

name of the last TAII file opened or accessed. It

also has the standard Windows control bar and

min/max controls.

Menu Bar a standard Windows item which gives access to

pull down menus that control the configuration

of the system, the target, and other TAII features

and functions.

Status Line this is where target and system information is

displayed.

Design Window this is where the visual touch/graphics design is

displayed as it is built.

Function Palette an icon based front end to TAII design tools.

Graphics Palette this is where the user may access all graphics

and text drawing functions.

Help Line provides context sensitive help.

3.1 The Title Bar

The title bar, a standard Windows characteristic, displays the program

title (Touch Assist II) and more importantly the name of the active

session, (the file name selected). The active session is named after the

file used for default file operations. If there is no default file, the

session is named "untitled".

The default file name is set whenever a file is opened or saved. These

operations are accessed through the "File" menu selection. Specifying

"new" from the file menu resets the default file to none.
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3.2 The Menu Bar

The menu bar consists of six pull down menus: File, Touch, Display

List, Config, Output, and Help. Standard Windows keyboard

accelerator techniques allow the menus to be activated by typing a

letter as well as by mouse activation.

3.2.1 File

TAII files are used to save and retrieve

sessions. A session is an instance of running

TAII and designing touch menus and graphics.

Sessions may be saved, retrieved, and

combined.

Many of the file operations available on the

File menu conform to standard Window 3.1.

Beyond the obvious file operation some file

menu items impact modes or other functions in

TAII, or provide additional capabilities.

New clears all defined objects from the session. All

graphics, buttons, menus, and list references are

erased. Many modes are reset to default values.

Example: Creating a File

Step 1. Select the File function from the Menu

Bar.

Step 2. Select New... from the choices presented.

Note: If you currently have information

on the screen (i.e. Graphics or

Buttons), a dialog box will prompt

the user to save this information.
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Step 3. At this point the user may create Graphics or

Buttons on the Touch Assist II Design

Window. (Refer to the examples in the

sections on Graphics and Buttons for

details.)

Step 4. After creating graphics or buttons on the

Design Window, select the Save As...

option from the File menu.

Step 5. Type the desired file name. (Standard DOS

filename rules apply.)

Step 6. Click the Save button. The user can verify

that the file has been saved by using

techniques discussed in the following

example.

Open is used to retrieve an existing session file. File

names are prompted for in dialog boxes associated

with these functions. The names supplied become the

session name appearing in the TAII title.

Example: Opening an Existing File

Step 1. Select the Open... function from the File

menu.

Note: If you currently have information

on the screen (i.e. Graphics or

Buttons), a dialog box will prompt

the user to save this information.

Step 2. Select the desired file from the choices

presented in the dialog box.

Step 3. Click the Open box.
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Copy allows user to copy an existing TAII file to any

desired directory. Dialogue windows are provided to

enter file name and destination.

Example: Copying a File

Step 1. Select the Copy function from the File

menu.

Step 2. Select the file to be opened from the choices

provided within the Open File Name box.

Step 3. Position the mouse inside the Copy to Dir.

box and click the left button on the mouse.

Step 4. Type the path of the desired file to be

copied.

Step 5. Click the Open button. This will activate the

desired file.

Append is used to combine sessions. The file specified in the

append operation is combined with the current

session. Appending does not change the session

name. When appending files, buttons on pages are

combined and care must be taken if buttons overlap.

Another possible problem encountered in append

operations is references to files as display lists.

When the current session and the appended session

both name a file as a particular display list, the

appended files reference stands as the one used from

then on.

Example: Using the Append Function to Combine

a File

Step 1. Open the desired file to be appended using

techniques discussed in the Opening a File

example.
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Step 2. Select the Append option from the File

menu.

Step 3. Select the target file from the choices

provided.

Step 4. Click the Execute button. A dialog box will

prompt the user to cancel or proceed.

Step 5. Click the OK button.

Step 6. The first file will now be combined under

the heading of the target file that was

selected.

Save/Save As are used to store session information.

Example: Saving a File

Step 1. Select the File function from the Menu Bar.

Step 2. Select the Save option from the choices

provided.

Note: A file may be saved at any time

after it is created or opened.

Example: Using the Save As... Function

Step 1. Follow steps 1-4 from the Example:

Opening an Existing File.

Step 2. Select the Save As... option from the File

menu.

Step 3. Type the new file name in the File Name

dialog box.
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Step 4. Click the Save button.

Note: The original file will still exist under the

original file name. This is a useful tool

that will allow the user to test different

modifications of a program while leaving

the original intact.

View is used to examine the text information in any given

file created during a session. The desired file must

be converted to an ASCII file before it can be

viewed. See Output mode.

Example: Viewing a File

Step 1. Select the View option from the File menu.

Step 2. Select the desired file to be viewed from the

choices provided.

Step 3. Click the Open box. At this time the file

will be display in ASCII form.

Step 4. To return to the Touch Assist II Design

Window, select the Exit button from the

File menu.

Note: All files must be compiled into ASCII

form before they can be viewed. Refer to

the Example: Creating an ASCII File in

the Output Menu section.

Delete is used to delete any given file found under the TAII

directory. All information associated to the file will

be lost.

Example: Deleting a File

Step 1. Select the Delete option from the File menu.
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Step 2. Select the desired file to be deleted from the

choices provided.

Step 3. Click the Execute button. At this point a

dialog box will prompt the user to cancel or

proceed.

Step 4. Click the OK button to proceed with the file

deletion or click the Cancel button to

cancel.

Exit terminates the program session.

Example: Exiting Touch Assist II.

Step 1. Select the Exit option from the File menu.

Step 2. At this point a dialog box will prompt the user to

Save file or Cancel

Step 3. Clicking the Yes button will save the file prior to

exiting TAII. Clicking the No button will exit TAII

without saving the changes made to the current file.

3.2.2 Touch

Parameters which control touch application

generation are accessed through this menu.

LCSP products support many modes of

operation which change the look and feel of

touch buttons and menus as well as more

rudimentary touch functionality. These

modes are accessible from the "Modes"

item of the Touch menu. For detailed

descriptions of these modes, refer to the

product manual of the device. Typically,

the default values used by TAII are

sufficient.
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The Touch menu also allows the designer to view the current

application in different ways. A hierarchical view is supported by the

"View App" item. In this view, all pages are shown in a simple list

structure. Individual elements of the page, buttons and graphic

objects, are described. The list can be scrolled to view all pages and

their elements. The detailed specifications of individual buttons on a

page can be viewed by clicking on button item (buttons are identified

by their label).

Another view supported is the "whole page" view selected by the

"View Page" item of the Touch menu. This view shows the entire

page in a single window. The page elements, buttons and graphic

objects, are shown exactly as they are in the Design Window. Unlike

the Design Window however, a simulation of the entire screen of the

target device is shown.

The "Print Page" item of the Touch menu prints the view offered by

"View Page". The printing is done through the standard windows

printer driver.

Example: Configuring Touch Button Report Modes

Step 1. Select the Modes option from the Touch menu.

Step 2. Select the desired button report mode(s) from the choices

provided. An "X" in the box of any given mode will enable

that mode.

Step 3. Click the Set button.

Note: Clicking the Reset button will return all settings

back to factory default settings. Clicking the Exit

button will return the user back to the Design

Window causing all changes to be deleted.

Example: Viewing a Page Summary

Step 1. Select the View App... option from the Touch menu. At this

point the user will be able to view a summary of the button

pages which have been defined by the current program.
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Step 2. The user may view the attributes and responses of any

particular button by double clicking the icon representing the

desired button with the mouse. Clicking the Exit button will

return the user to the Page Summary screen.

Step 3. To exit the Page Summary screen, click the Control Menu

box at the upper left hand corner of the screen. Select Close

Alt +F4 from the options listed. An alternative method of

closing the Page Summary screen would be to double click

the Control Menu box.
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Example: Viewing a Page

Step 1. Select View Page from the Touch menu. At this time the

Design Window will be maximized.

Step 2. To exit the full page screen, click the Control Menu box at

the upper left hand corner of the screen. Select Close Alt

+F4 from the options listed. An alternative method of closing

the full page screen would be to double click the Control

Menu box.

Example: Printing a Page

Step 1. Open an existing file or created a new file using techniques

discussed in the File Menu section.

Step 2. Select Print Page from the Touch menu. At this time the

page will be printed.

Example: Using Test Mode

Step 1. Open an existing file or created a new file using techniques

discussed in the File Menu section.

Step 2. Select the Test Mode option from the Touch menu. To

disengage the Test Mode option, simply click the option a

second time with the mouse pointer.

Note: 1) All TAII Menu functions, Function Palette

Icon, and Graphics Palette functions are

disabled while in Test Mode.

2) Positioning the mouse onto a button and

clicking the left button once emulates activating

the button.

3) Pop-up menus will appear at the upper left

hand corner of the Design Window regardless

of the coordinates specified by the button

parameters. However, they will be positioned

correctly upon download to the target unit.
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4) Test Mode will not emulate a Button Capture

response as described in the Button section.

5) Host mode may be enabled prior to activating

Test Mode. Host mode will allow the user to

view the host responses of any button activated

while in Test Mode.

3.2.3 Display Lists

Display lists are a feature in LCSP products.

A display list is a sequence of commands which

are grouped together and may be referred to by

a single numeric ID. They are used as macro

commands. In the product, these commands

can be stored locally, often in non-volatile memory, so that the host

system can execute the entire command macro by issuing a single

simple instruction to the unit. This saves on communication overhead

and helps embed local intelligence and flexibility in the target unit.

TAII provides a means to define and use display lists when designing

applications.

In TAII, display lists can be used to couple graphics and touch menus.

The action (local response) of a button may be to invoke a display list.

The list contents, graphic commands, are executed resulting in graphic

images on the screen. A local response may also contain a command

to change button pages. By doing both in a local response a button

may change button pages and efficiently draw its associated graphics.

Buttons on many different pages may use the same local response

combination of page change and display list. See examples section to

learn how to create and use a display list.

Display lists are referenced as separate files in a TAII design. These

files typically will contain frequently used graphics. In fact, a file

referenced as a display list may contain graphics, or graphics

generated text. Attempting to reference a file which contains touch

menu definitions as well will result in an error. To reference a file as

a display list in a TAII session, use the "Define List" item in the

Display List menu. The dialog box invoked by this item asks for the
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numeric ID of the list and the file to be referenced. The ID is then

used throughout TAII to reference the display list.

The Display List menu allows lists to be deleted. Deleted lists will not

be downloaded or otherwise specified in output file. References to

deleted lists, such as in the local responses of buttons, are not deleted.

LCSP products will correctly ignore references to non-existent lists.

The "View List" item of the Display List menu displays a graphical

directory of all defined lists and the logical contents of the lists.

Example: Creating a Display List

Step 1. Select the Define Lists... option from the Display List menu.

Step 2. Input any desired number from 1 to 4000 into the Display

List I.D. dialog box. For this example, input a value of 1.

Step 3. Click the Open button within the Display List dialog box.

Step 4. Enter the name of a new (previously unused) file in the Open

File Name dialog box. For this example, input the word:

Circle

Step 5. Click the Open button within the Open File Name dialog

box.

Step 6. At this point the user is ready to input data to the display list.

Draw a circle with no fill on the Design Window using

techniques described in the Graphics Examples section.

Step 7. After defining all the graphics to be entered into the display

list, click the Exit button within the Exit Capture dialog box.

Step 8. At this point, the user has created a display list that can be

accessed as part of a button response whenever necessary.

Refer to the section on Button Responses for further details.
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Example: Deleting a Display List

Step 1. Select the Delete List option from the Display List menu.

Step 2. Enter the number of the display list to be deleted into the

Display List I.D. box.

Step 3. Click the OK button. This will cause the specified display list

to be deleted.

Example: Viewing Display List Summaries

Step 1. Select the New option from the File menu in order to create a

new file.

Step 2. Select the View List option from the Display List menu. The

user will be presented with a visual representation of the

display list.

Step 3. Double clicking any given box representing a display list

allows the user to view the ASCII information contained

within the list. Click the Exit button to return to the Display

List Summary.

Step 4. The vertical scroll bar located at the right hand side of the

screen allows the user to advance the summary towards

additional lists as necessary.

Step 5. To exit the Display List Summary click the Control Menu

Bar and select Close Alt + 4 from the available options.
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3.2.4 Config

Configuration refers to both the

development system (the PC running

TAII under Windows) and the target

LCSP product.

The LCSP product to be used as the target of a TAII design is selected

from the "Module" item. The LCSP products are identified by their

controller model number (C3, C4, C320, etc.). To select one, click

the selection box near the name. The selection of the target implicitly

selects the screen dimension and insures proper translation of the TAII

design to output format.

To download and test a TAII design, the target product must be

connected to the PC serially. The serial link and data transfer

formatting between the PC COM port and the target must be defined

correctly. The serial link, and data transfer formatting are defined

using the "Communication" item on the "Config" menu. (Recommend

using 9600 Baud, 8 Data Bits, 1 Stop Bit and No Parity for all LCSP

products.)

Example: Sending a Reset to the Target Terminal

Step 1. Select the Reset option from the Config menu. At this point

the user will be prompted to save the current file or cancel.

Step 2. Click the Yes button to reset the target terminal after saving

changes to the current file. Click the NO button to reset the

target terminal without saving changes to the current file

Example: Configuring Touch Assist II for a Specific Module

Step 1. Select the Module option from the Config menu.

Step 2. Point and click the mouse in the circle beside the appropriate

terminal. Refer to the following list of compatible terminals

by category. Each selection can be toggled on and off by

rechecking the same selection.
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C320 (640x200/640x400): C4 (640x400):

M320ST/M320ST-AC M4ST

ST2200 ST3220

ST2200XT ST3225

ST2205 ST3420

ST2400

C3 (512x256): C6 (640x480):

M3 M6ST

M3-15 ST4230

Step 3. Click the OK button to activated the configuration. Click the

Cancel button to cancel the selection.

Example: Setting Communication Port Settings

Step 1. Select the Communication option from the Config menu.

Step 2. Point and click the mouse in the circle beside the appropriate

configuration selection. For details regarding communication

requirements, refer to the Applications manual for the specific

unit.

Step 3. Click the OK button to activate the selected communications

settings. Click the Cancel button to cancel the settings.

3.2.5 Output

Output allows the user to convert files into

various forms such as, ASCII, COBAL, and

ASSEMBLY.

Download is used to transfer files to an attached LCSP target unit.

TAII translates the files into appropriate command sequences as it

downloads over the serial link.
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Example: Downloading a File to a Target Terminal

Step 1. Select the Download option from the Output menu. At this

time the user will be prompted to save any active file. Click

the YES button to save any changes made to the current file.

Step 2. Select the file to be downloaded from the options available.

Step 3. Click the Execute button. At this time, the user will be

prompted with a list of conditions to be activated during

download. Select the appropriate conditions for the download.

Step 4. Click the OK button to proceed with the download.

Example: Outputting Files for use in Alternate Programming

Modes (ASCII, Cobal, ASM)

Step 1. Select New from the File menu to create a new file.

Step 2. Select the C Format option from the Output menu.

Note: The procedure is identical for all three options.

Step 3. Clicking on the C Data format will create a file in the Touch

Assist II sub-directory with the appropriate extension. (For

this example it would be XXXX.C) This will not be a

compiled file, it is a co-generated file with a format change.

This will allow the user to call up the file as a routine within a

program.

Step 4. The ASCII formatted file is viewable using the View option

from the File menu. Cobal and Assembly formatted files are

viewable outside the Touch Assist II environment only. The

user will have to use standard DOS commands or a file

management program.
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3.2.6 Help
TAII utilizes a standard Windows help

facility. An index is provided for

common TAII procedures and concepts.

The index is accessed via the "Index"

item. To get help on Windows help

facility, use the "Using Help" item.

Example: Using Help

Step 1. Select the Content option from the Help menu.

Step 2. Position the mouse pointer on the desired subject of inquiry.

Step 3. Click the left button on the mouse.

Step 4. Follow instructions on the screen.

3.3 The  Design Window

The Design Window is where graphics images and touch menus are

drawn and laid out. It represents a portion or all of the physical

screen of the LCSP touch/graphic product, depending upon which

terminal mode has been selected.

The portion of the physical screen which is viewed may be changed (if

necessary) by the scroll bars on the bottom and side of the Design

Window. The physical coordinates of the viewed portion are
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displayed in the Status Line "Screen" field. The four numbers of the

Screen field denote the left, top, right, and bottom coordinates,

respectively, of the viewed screen portion. These coordinates are

physical screen coordinates and assume that the origin is at the top left

of the physical screen.

The target LCSP product and the current touch page are identified in

the title of the Design Window. The page number is selected from the

slide switch in the Status Line. The product type is selected from the

"Module" item of the "Config" menu. The product type defines the

screen size and the number of available pages.

The Status Line also displays the coordinates of the mouse cursor

when it is active in the Design Window. This is helpful for precision

placement of objects in the Window. The coordinates are terminal

dependent and will vary accordingly with the terminal selected under

the "Config" set-up menu.

3.4 The Function Palette

The tools represented by the Function Palette icons allow the creation

and manipulation of touch buttons and pages, and the manipulation of

graphics and text. This palette holds all the graphic edit functionality

such as cut and paste, move, re-size, and delete as well as the button

definition functionality.

Items on the palette are selected by moving the cursor to them and

clicking. Some functions, such as the edit functions are modal; that

is, they are a mode of operation and the mode continues until another

function is selected. Functions such as button creation are not modal;

they cause an immediate action. The significance of modal functions

is that they inhibit non-modal functions and graphic draw operations.

It is not possible to draw graphics in the Design Window during a

modal operation. The meaning and function of the mouse cursor in

the Design Window is tied to the modal operation in effect. Modal

functions are
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terminated by selection of another function or by selecting an object

from the graphic palette. The current mode may be identified by the

appearance of the corresponding function palette button to the right of

the function palette. The absence of any identifier means that non-

modal operation are allowed.

3.4.1 Host

The Host function refers to an additional window, the Host Window,

which can be displayed on the screen. The Host window displays

information which is transmitted from the LCSP product connected to

the COM port of the PC. The Host function toggles the displays of the

Host Window and current screen.

The COM port and its configuration is specified from the

Communication item of the Config menu.

Example: Using the Host Function

Step 1. Select the New option from the File menu.

Step 2. Select the Host function from the Function Palette. A blue

dialog strip will appear at the bottom of the screen.

Step 3. Create a button as described in Button Example 1.

Step 4. Select Test Mode from the Touch menu.

Step 5. Click the button located within the Design Window with the

mouse pointer. The user will notice the host response within

the blue dialog box at the bottom of the screen.
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3.4.2   Cut,    Copy  and    Paste

Cut and Copy work together with paste to allow the movement of

graphic items from one page to another. They are modal operations

and will be in affect until another function is selected. Typically this

other function will be Paste. Cut and Copy only differ in how the

source objects are treated in the ensuing Paste operation. If the objects

are Cut, they will be deleted when the paste happens, if they are

Copied, the will remain unaffected by the paste. The following

description of the cut operation pertains to copy as well, except for the

behavior noted.

An item or group of items is selected during a cut operation by

creating a cut area. The cut area is a rectangular region encompassing

all the desired items. An item must be fully contained within the cut

area to be affected. The cut area is created by moving the mouse

cursor to the top left of the desired region, pressing the left mouse

button, and dragging the mouse (moving it with the button depressed)

diagonally to the lower right corner of the desired region. The cut

area will be identified by a dotted rectangle which rubber-bands as the

mouse is dragged.

The cut area will be removed from the screen (cut) when the paste

operation has been selected and performed. To paste, select the page

where the item is to be pasted using the page slide switch in the Status

Line; then select the Paste function from the function palette. The cut

area will be positioned on the new page at the same relative

coordinates it held on the original page. It can then be moved, if

desired, to a new relative position by using the move function (icon).

Example: Cut and Paste Function

Step 1. Select the New option from the File menu.

Step 2. Define a circle on the Design Window as described in the

Graphics examples.

Step 3. Select the Cut function from the Function Palette.
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Step 4. Place the mouse pointer at a point above and to the left of the

circle. Click and drag the mouse until a dotted box fully

encloses the graphic.

Note: The cut function can only be used to transfer items

to other pages. It cannot be used to move and

object around on the same page.

Step 5. Click the right arrow on the page change slide switch located

on the status line just below the menu bar. This will change

the Design Window to a new page. The current page number

is displayed in the title bar of the Design Window.

Step 6. Select the Paste function from the Function Palette.

Step 7. Place the mouse pointer at the desired location of the object to

be pasted and click the left button on the mouse. Upon

releasing the button the object will appear at the new location.

Example: Copy and Paste Function

Step 1 Select the New option from the File menu.

Step 2. Define a circle on the Design Window as described in the

Graphics examples.

Step 3. Select the Copy function from the Function Palette.

Step 4. Place the mouse pointer at a point above and to the left of the

circle. Click and drag the mouse until a dotted box fully

encloses the graphic.

Step 5. Click the right arrow on the page change slide switch.

Step 6. Select the Paste function from the Function Palette.
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Step 7. Place the mouse pointer at the desired location of the object to

be pasted and click the left button on the mouse. Upon

releasing the button the object will appear at the new location.

Note: Unlike the Cut function, the copy function will

leave the original object intact. Be careful when

copying buttons. Some button responses such as

pop-ups might required modification to be

compatible with their new location.

3.4.3 Erase

The Erase is a modal function that operates on graphic objects and

buttons. Objects and buttons are deleted and cease to be displayed

when erased.

CAUTION: THERE IS NO UNDO!

To erase an object, select the erase function and move the mouse

cursor to the object to be erased. Clicking the left mouse button will

erase the object. Care must be taken when erasing an object which

overlaps or is overlapped by another object. The mouse cursor should

be in a non overlapped region of the desired object before it can be

clearly identified. If this is not possible, such as in the case of

completely overlapped objects, it is suggested that the items be moved

to isolate the desired object of erasure.

Example: Erase Function

Step 1. Select the New option from the File menu.

Step 2. Select the circle option from the Graphics Palette.

Step 3. Define a circle as described in the Graphics examples.
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Step 4. Select the Erase function from the Function Palette.

Note: When any function from the function palette is

selected, the icon for that function will appear at

the upper right hand corner of the screen.

Step 5. Place the mouse pointer within the area of the circle and click

the left button on the mouse. This will cause the graphic to be

erased from the Design Window.

Step 6. Choosing any other function or menu item will deactivate the

Erase function.

3.4.4 Edit

The edit modal function is used to resize graphic objects and buttons.

To resize an object select the edit function and move the mouse cursor

on or near the desired object and click the left mouse button. Edit

markers will appear at various points on the object. The number of

points depends on the type of object selected. When the mouse cursor

is placed on any of these edit markers and the left button is pressed,

dragging the mouse will resize the object. Polygon objects can be

reshaped as well as resized in the edit mode.

Example: Edit Function

Step 1. Select the New option from the File menu.

Step 2. Define a rectangle as described in the Graphic examples.

Step 3. Select the Edit function from the Function Palette.

Step 4. Place the mouse pointer within the area of the rectangle and

click the left button. Dark boxes will appear on each corner of

the rectangle.
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Step 5. Click and drag one of the corner squares to modify the size of

the rectangle. Once the left button of the mouse is released,

the rectangle will be positioned at that coordinate.

3.4.5   Single Move and    Group Move

Single and Group Move modal operations are used to move objects,

graphic and touch, on a given page.

Moving objects starts with identifying them. For single object moves

the object is selected by moving the mouse cursor onto the object and

pressing the left button. The object will be identified by a surrounding

dashed box and the move icon will appear. Groups of objects are

selected by moving the cursor to a point above and to the left of the

items and pressing the left mouse button. By then dragging the mouse

a dashed box is created which can be used to encompass the desired

objects. The mouse cursor can be moved into the box and the left

mouse button pressed to obtain the move cursor. Once the move

cursor is obtained, in either case, it will remain until the left mouse

button is released. By dragging the mouse with the left button pressed,

the object or objects can be repositioned to any desired location.

Releasing the left mouse button will leave the moved objects

permanently in their new position. When moving a group of objects,

only those contained entirely inside the box will be moved. All other

objects will be left unchanged.

Example: Single Move Function

Step 1. Select the New option from the File menu.

Step 2. Create a rectangle as described in the Graphics examples.

Step 3. Select the Single Move from the Function Palette.

Step 4. Place the mouse pointer within the area of the rectangle and

click the left button. A dotted line representation of the object

will appear and a hand will replace the mouse cross-hairs.



Deeco� Systems Touch Assist II

Page 29

Step 5. Click and drag the object with the mouse to the desired

location.

Step 6. Once the mouse button is released, the object will be

positioned and the mouse pointer will resume a cross-hair

configuration.

Example: Group Move Function

Step 1. Select the New option from the File menu.

Step 2. Create a rectangle as described in the Graphics examples.

Step 3. Select the Group Move function from the Function Palette.

Step 4. Place the mouse above and to the left of the region to be

moved.

Step 5. Click and drag the mouse until a dotted rectangle

encompasses the objects to be moved. At this time, release the

mouse button to define the region.

Step 6. Place the mouse pointer within the area of the rectangle and

click the left button. A hand will replace the mouse cross-

hairs.

Step 7. Click and drag the object with the mouse to the desired

location.

Step 8. Once the mouse button is released, the object will be

positioned and the mouse pointer will resume a cross-hair

configuration.
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3.4.6 Fine Move

The Fine Move function can be used to accurately place an object to

the pixel level. The object is selected by clicking it. The four arrow

keys of the keyboard may then be used to move the object up, down,

left, or right. The cursor moves with the object and the mouse

position reported in the status line is maintained so the position can be

monitored during the move.
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Example: Fine Move Function

Step 1. Select the New option from the File menu.

Step 2. Create a rectangle as described in the Graphics examples.

Step 3. Select the Fine Move function from the Function Palette.

3.4.7 Auto-Arrange

This modal function is useful in formatting various touch and graphic

objects in the Display Window. A group of items may be arranged

within a rectangular region with constant inter-object spacing.

First a group of objects is selected for arrangement. This is done by

drawing a dashed selection box around the object. Move the mouse

cursor to a point above and to the left of the desired group of objects.

Press the left mouse button and drag the mouse to a point below and to

the right of the objects. The resulting dashed box will contain all the

objects to be included in the auto-arrangement function. The next step

is to define a region where the arrangement is to be placed. This may

be anywhere on the current page and is created in a similar fashion to

that of the selection area. The size of the arrangement determines the

order and spacing of the final arrangement.

Example: Auto Arrange Function

Step 1. Select the New option from the File menu.

Step 2. Create four rectangle at various positions on the Design

Window. Use techniques described in the Graphics

examples.

Step 3. Select the Auto Arrange function from the Function Palette.

Step 4. Place the mouse pointer above and to the left of the region to

be arranged.
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Step 5. Click and drag the mouse until the dotted rectangle

encompasses the region to be moved. Release the left button

on the mouse to define the region.

Step 6. Click and drag the mouse to define a rectangular region

starting at the following coordinates: X=50, Y=200 and

ending at the following coordinates: X=400, Y=150.

Step 7. Release the left button on the mouse to define the region. The

objects are automatically aligned according to the defined

region.

3.4.8 Place Button

Place Button creates a button on the current page and allows the

placement (positioning) of the button of the current Design Window

page.

When actuated, Place Button invokes a dialog box. Within the dialog

box is the rough placement grid. This grid represents the Design

Window and its cells are possible button locations. The number of

cells is a function of the default button size. Button size is determined

by the template function. Clicking a grid cell places a button of the

current default size at a corresponding location in the Design

Window. (Clicking again at the same location will erase the button.)

The button may be moved or resized later with the edit and move

functions.

The button placement dialog box gives access to another dialog box,

the template editor. The template, as mentioned above, is the default

button size. It is characterized by the rectangle of the resulting button

and by the inter-button spacing. The template editor allows the

rectangle and spacing to be specified.

The button placement dialog box also displays button resource

information. Many LCSP touch products allow only a fixed number

of button regions. A button region is defined by position as well as

shape. Button regions may be used on multiple pages, and always

have the same position and shape.
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Once a button has been placed on the page its function and appearance

may be defined. The design and development of touch menu systems

is discussed in greater detail in the examples section.

Example: Create a Button with Default Dimensions

Step 1. Select the New option from the File menu to create a new

file.

Step 2. Select the Place Button icon on the Function Palette.

Step 3. Click one square from the grid located within the Assign

Button Location dialog box.

Step 4. Click the Exit button. At this point a single button box will be

created on the Design Window. Double click the button with

the mouse.

Step 5. Select the Button Label dialog box and enter: B1.

Step 6. Select the Host Response dialog box and enter: Button 1.

Note: This response will be the response received by the

host system and can be seen while in Touch Assist

test mode when the Host mode is activated from

the Function Palette.

Step 7. Click the Exit button with the mouse. At this point a

functioning button will be created on the Design Window.

Step 8. To test this buttons function, select Test Mode from the

Touch menu and click the button with the mouse pointer.

Note: All other Touch Assist functions are disabled while

in Test Mode.
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3.5 The Graphics Palette

The graphics palette can be thought of as an extension to

the function palette. In the absence of any modal

function, the graphics palette selection becomes active.

Graphics drawing is, in effect, the default mode. The

active graphic shape is identified by highlight.

Two attributes control the appearance of lines and

region and are selectable from the graphics palette. The

line style controls the appearance of vectors and polygon

and circle borders. These can be solid, dashed, or

dotted. The current selected is indicated by a small

square marker to the right of the active attribute. To

change the line style, move the mouse to the desired

style and click the left button. Fill style controls the

appearance of filled regions. The active fill style is

indicated by highlight. It can be changed by moving the

mouse to the desired style and clicking the left mouse

button.

Example: Shaded Shape Options

Step 1. Select the New option from the File menu to create a new

file.

Step 2. Select the shaded square option from the Graphics Palette

located at the left side of the screen.

Step 3. Observe the shading style options at the bottom of the

Graphics Palette. Select the Vertical Hatch option.

Step 4. Place the mouse pointer on the Design Window. Click and

drag the mouse to create a rectangle 50 pixels high by 100

pixels long. Mouse coordinates are reported on the status line

just below the Menu bar.

Note: In order for the Shading option to function, the

solid line style option must be active.
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Step 5. Select the shaded triangle option from the Graphics Palette.

Step 6. Select the left diagonal shading option.

Step 7. Place the mouse pointer on the Design Window and click the

left mouse button at the desired location for the first vertice of

the triangle. Repeat this procedure for each of the three

vertices of the triangle.

Note: The mouse pointer cannot leave the Design

Window until all three of the triangle's vertices

are defined.

Example 2: Non-Shaded Shapes Options

Step 1. Select the New option from the File Menu to create a new

file.

Step 2. Select the circle option from the Graphics Palette located at

the left side of the screen.

Step 3. Observe the line style options located just below the shape

options in the Graphics Palette. The solid line is the default

option and is identified as being active by a small square to

the right of the line.

Step 4. Select the dotted line option just below the solid line option by

clicking the mouse directly over the image of the line.

Step 5. Place the mouse pointer on the Design Window. Click and

drag the mouse until a circle with a diameter of 250 pixels is

created.

Step 6. Select the polygon option from the Graphics Palette.

Step 7. Place the mouse pointer on the Design Window and click the

mouse at the desired location for the first vertice of the

polygon.

Step 8. Reposition the mouse and click the left button for each vertice

of the polygon.
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Step 9. Click the right button on the mouse to close the polygonal

shape.

Note: The mouse cannot exit the Design Window until

the right button on the mouse is pressed.

3.5.1 Vectors

Two types of vectors are supported: random and orthogonal. Random

vectors can be any orientation. Orthogonal vectors are always parallel

the X and Y axes. The methods for drawing either vector type are the

same, though the results will be different.

Example: Drawing a Vector

Step 1. Move the mouse cursor in the Design Window to the desired

start point, and click the left mouse button

Step 2. Move the mouse to the desired end point and click the left

button again.

Note: The vector will appear when the endpoint has been

defined.

Example: Drawing a Vector (rubber band method)

Step 1. Move the mouse to the desired start position, press and hold

the left mouse button; move the mouse to the desired stop

location and release the left button to complete the vector.

Note: In the rubber band method you will observe a

dashed vector starting at the selected start point

and terminating at the mouse cursor. This dashed

vector moves as the mouse is moved and represents

the final vector if the mouse button were to be

released.
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3.5.2 Arcs

Arcs are sections of circles and are defined by three points.

Example: Drawing an Arc

Step 1. Select the Arc option from the Graphics Palette.

Step 2. Move the mouse cursor to the desired positions and click the

left mouse button.

Note: The first position will define one end point of the

arc.

Step 3. Repeat Step 1 for points 2 and 3 of the Arc.

Note: The second position will define the opposite end

point of the arc. The last position will define any

given point on the curve of the arc itself. The arc

will be drawn upon the specification of the third

point.

3.5.3 Circles

Circles may be filled or unfilled. Unfilled circles will use the current

line style for the border but filled circles will always use a solid

border.

Example: Drawing a Circle

Step 1. Select the circle option from the Graphics Palette.

Step 2. Move the mouse to the center of the desired circle, press and

hold down the left mouse button.

Step 3. Drag the mouse with the left button held down.

Note: An ellipse with a dashed border will appear and

will move as the mouse is moved.
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Step 4 Release the mouse button.

Note: The dashed ellipse will become a circle with the

selected attributes. The radius of the resulting

circle is always the minor (smaller) axis of the

ellipse.

3.5.4 Rectangles

Rectangles may be filled or unfilled. Unfilled rectangles will use the

current line style for the border but filled rectangles will always use a

solid border.

Example: Drawing a Rectangle (2 Point Definition)

Step 1. Select the Rectangle option from the Graphics Palette.

Step 2. Click the left button at the coordinates that make up the

opposite vertices of the rectangle.

Example: Drawing a Rectangle (rubber rand method)

Step 1. Select the Rectanlge option from the Graphics Palette.

Step 2. Move the mouse to the corner of the desired rectangle. Press

and hold the left button of the mouse while dragging the

mouse. An outline of the dsired rectangle will be displayed.

Step 3. Release the left button of the mouse to define the rectangle.
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3.5.5 Triangles

Triangles may be filled or unfilled. Unfilled triangles will use the

current line style for the border but filled triangles will always use a

solid border. Triangles are specified by three points.

Example: Drawing a Triangle (Three Point Method)

Step 1. Select the Triangle option from the Graphics Palette.

Step 2. Three points should be identified by moving the mouse to

each point and clicking the left mouse button. The triangle

will be drawn upon specification of the third point.

Example: Drawing a Triangle (rubber band method)

Step 1. Select the Triangle option from the Graphics Palette.

Step 2. Move the mouse to the coordinate of the first vetex of the

desired triangle, press and hold the left mouse button while

dragging the mouse to the location of the second vertex of the

triangle.

Step 3. Release the left button of the mouse. The base line for the

triangle will be defined.

Step 4. Move the mouse to the coordinate of the third vertex of the

desired triangle and click the left button. The entire triangle

will be displayed.
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3.5.6 Polygons

Polygons may be filled or unfilled. Unfilled polygons will use the

current line style for the border but filled polygons will always use a

solid border.

Example: Drawing a Complex Polygon

Step 1. Select the Polygon option from the Graphics Palette.

Step 2. Polygons are specified by their vertices. To specify a vertex

move the mouse to the desired location and click the left

mouse button.

Step 3. Starting with the second vertex, edges joining the two last

vertices will appear as new vertices are specified.

Step 4. To complete the polygon click the right mouse button. This

will draw an edge from the last vertex to the first vertex.

Note: The user may define up to 32 vertices. After 32

vertices are selected, the polygon will

automatically close itself.

3.5.7 Text

It is possible to alter the visual appearance of text. Font, size,

rotation, as well as such attributes as underline, italics, and reverse

video may be changed. String path, how successive characters are

placed relative to one another, may also be changed. The Text

Attribute dialog box, which allows changes to these attributes, is

accessed by double clicking the text icon on the graphics panel.
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Fonts are referred to by the Char Set number. The number of sets

available depends on the target. A character is scaled in LCSP

products by pixel replication. The size of the pixel is selectable as an

integral multiplier of the base pixel size. Orientation refers to

character and string rotation, which is in multiples of 45 degrees.

Path refers to successive character placement and may be left-to-right,

bottom-to-top, right-to-left, or top-to-bottom.

Example: Drawing Graphical Text

Step 1. Select the Text option from the Graphics Palette.

Step 2. Move the mouse to the start position (lower left) of the

desired text string and click the left mouse button. A dialog

box will appear where the ASCII text may be typed.

Step 3. Type the following text string: �This is an example of the

text function.�

Step 4. Select the OK button to draw the text in the Design Window.

Selecting the Cancel button will cancel the operation without

displaying any text.
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3.6 Status Line

The Status Line displays information about the Design Window. The

screen extent represented by the design window, the mouse position

within the design window, and the status of the communication link to

the LCSP product connected to the COM port are shown.

The button page (menu) currently displayed in the Design Window is

selectable from the Status Line. The slide switch controls which page

is displayed within the Design Window. The page number identifying

the current page is displayed within the title of the Design Window.

3.7 The Help Line

Context sensitive help appears on the Help Line. As functions from

the Function Palette or objects from the Graphics Palette are selected,

messages are displayed on the Help Line describing options or

required actions to complete or modify the function.

4.0 Application Development

The application generation process centers around the creation of

touch menus, or pages. A page is a group of buttons collectively

displayed on the target module screen and referred to by a single

numeric ID, the page number. The page number is selected by

moving the page slide bar, (or clicking on the advance bar arrows), on

the Status Line. The page number is visible in the Design Window

header.

Graphics screens may be generated and saved independent of touch

constructs, however the graphics designed on a page with buttons

becomes part of that page. This coupling of graphics and touch menu

is done automatically by TAII and it is done in the local response of

buttons which change pages. When the change page is specified as

part of the response TAII adds the graphics commands required to

draw the images associated with that page.
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The LCSP product to be used as the target of a TAII design is selected

from the "Module" item. The LCSP products are identified by their

controller model number (C3, C4, C320, etc.). To select one, click

the selection box near the name. The selection of the target implicitly

selects the screen dimension and insures proper translation of the TAII

design to output format.

4.1 Touch Menu Generation

Touch menu, or button page, generation starts with the layout of the

buttons on a page. Pages are referenced by a numerical ID, starting at

zero (0). Typical applications start with page one (1) reserving page 0

for special use (many LCSP products attach special features to page

0). Each page contains a different menu and, perhaps, graphic

images.

4.1.1 Button Placement

Enter the rough button placement dialog box using the button

function. Use the placement grid to place as many buttons as the page

requires. When the correct number of buttons have been selected exit

the dialog box to complete the fine positioning and sizing of the

buttons.

Sizing of buttons, if the default is not sufficient, may be accomplished

by editing the button. Select the edit function and then select the

button for editing by clicking on it. Edit markers will appear enabling
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the button to be re-sized. Move the mouse to any of the markers, click

and drag the marker to re-size.

Example: Create a Button using Template Dimensioning

Step 1. Select the New option from the File menu.

Step 2. Select the Place Button icon as in Example 1A.

Step 3. Click the Template button in the Assign Button Location

window.

Step 4. Move the mouse into the work area to the left of the Button

Size window.

Step 5. Click and drag the mouse until you create a button with a

width and a Height of 100 pixels. Button dimensions can be

observed in the Button box to the right of the work area.

Step 6. Select the Gap dialog box and enter a value of 5.

Step 7. Click the OK button with the mouse.
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Step 8. Select two adjacent boxes from the grid located in the Assign

Button Location window.

Step 9. Repeat Steps 3-7 of the example in section 3.4.8 for each of

the two buttons created.

Step 10. To test each button, refer to Step 8 of the example in section

3.4.8.

If a new default size is desired, the template defining the default may

be changed. The Template editor is entered through the "Template"

button in the placement dialog box. The size of the default may be

defined by creating a box in the edit area of the desired size. The box

is drawn by moving the mouse to a convenient point representing the

upper left corner, pressing the left mouse button and dragging the

mouse to the lower right corner. The height and width is shown in

pixel size and updated as the box is defined. Release the mouse button

when the desired size is obtained.

The inter-button space may be entered explicitly by editing the spacing

number. The inter-button spacing refers to how close buttons will

appear when placed using the placement grid. The placement grid will

adjust according to the defined default size and inner button space.
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Once placed, use the single or fine move function to position the

button. Select the function and the button to be moved. The

appearance of the move cursor (a small hand) enables the button to be

moved and placed anywhere in the Design Window.

Example: Changing the Size of an Existing Button

Step 1. Select New from the File menu.

Step 2. Select the Edit function from the Function Palette.

Step 3. Click the target button with the mouse

Note: The button will be highlighted with blocks at each

corner.

Step 4. Click and drag one of the corner blocks until the button is of

the desired dimension.
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4.1.2 Button Response

To define a button's response, double click on the button to enter the

Button Response dialog box. The internal of a button is comprised of

one or more states; each state contains a label, a host message, and a

local response. The label is used as the visible text identifier of the

button, the host response is a message sent over the communication

link to the host system when the button is actuated, and the local

response is a command sequence replayed internally when the button is

actuated. Upon actuation the button automatically moves to the next

state displaying the new label. States may also be assigned different

visual attributes.

To define the label, click in the label edit box. (The cursor will

automatically default to the label box upon entering dialogue box.)

The text cursor will allow the entry of a text string which will be the

label for the state. Multiple line labels are defined by delimiting each

line with a carriage return generated by the key combination of
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SHIFT-6 then SHIFT-M. Labels are automatically centered, left to

right and top to bottom by the target device as well as TAII.

The host message is entered similar to the label. Click on the host edit

box to move the text cursor to that box. Enter the text of the message

from the keyboard. Control codes may be embedded by the

appropriate Control-<key> combination.

A local response is a sequence of target compatible commands which

are replayed through the device's command parser as if the commands
had come from the host. Any command which can be sent from the

host is possible to embed in a local response. The local response may

be entered in the same fashion as the label or host message. To embed

complex command sequences five pre-defined options are offered:

Capture Button embeds a command in the response which couples the

current button to another button, perhaps on another page. When the

current button is pressed in the target, the coupled button will also

appear to be pressed. This has the effect of changing the coupled

button's state. If the coupled button is on the current page, its label

will be updated but the host message will not be sent and its local

response will not be executed.
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Capture Page allows the designer to couple the current button to

another page of buttons. Pressing the button on the target will cause

the current button page to be erased and the new page to appear. The

graphics associated with the new page will also be embedded in the

button.

Capture Graphics embeds a sequence of graphic commands in the

response. It does this by displaying the current page in the Design

Window and allowing graphics to be drawn using Graphic Palette

functions. A small window appears on the screen containing

instructions on how to exit the capture mode. An Exit button is

offered within this small window which when clicked will exit and

return to the Button Response Dialog box.

Capture Display List embeds a display list into the local response of

the button. The list is specified by its numeric ID. A small dialog box

will appear as part of the capture process so that the ID may be

entered.

These options cover most response requirements. Except for the Pop-

up option, all options may be embedded in the same response. (If the

Pop-up button is chosen no other function (local response) may be

selected.) To embed options in a response, click on the selection box

of the options desired and then click on the "Capture" button. The

defining dialog boxes or procedures for each option will then appear.

The following examples will detail how to define buttons with the

above functions:

Example: Creating a Button with Button Capture

Step 1. Select New from the File menu.

Step 2. Define two buttons using the procedure outlined in Button

Example 1.

Step 3. Double click the first button with the mouse.

Step 4. Select Button Label and enter the word: One

Step 5. Select the Button box from the Local Response Capture

List.
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Step 6. Click the Capture button.

Step 7. Click the second button with the mouse.

Step 8. Click the Exit button in the Define Button Response

window.

Step 9. Double click the second button on the Design Window.

Step 10. Select Button Label and enter the word: Two

Step 11. Select the Graphic box from the Local Response Capture

List and click the Capture button.

Step 12. Select the rectangle icon from the Graphics Palette.

Step 13. Define a rectangle on the Design Window as described in

the Graphics examples.

Step 14. Click the Exit button from the Exit Capture window.

Step 15. Click the Exit button within the Define Button Response

window.

Note: Button Capture does not function within the Test

Mode of Touch Assist II. To observe the button

capture, the file must be downloaded to the target

unit.

Example: Create Buttons with a Page Change

Step 1. Select New from the File menu.

Step 2. Define a basic button as in Example 1.

Step 3. Select the Page option box from the Local Response Capture

List for the local response.

Step 4. Click the Capture button located at the bottom right of the

Define Button Response dialog box.
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Step 5. Select the Page Number box and enter a value of 1.

Note: Any value from 1 to 199 can be selected.

Step 6. Click the OK button with the mouse.

Note: The Sealtouch command for the page change is

automatically entered into the local response box.

This code can be edited by the user at any time.

Step 7. Click the Exit box to the right of the Define Button Response

dialog box.

Step 8. Go to the Page Change Slide Switch located within the

Status Line just under the Menu Bar. Click the right arrow

or slide the scroll bar until you reach the desired page

number. The current page number will be displayed in the

Title Bar of the Design Window. For this example, select

Page 1.

Step 9. Repeat Steps 1-6 to create a return button. For Step 4 enter a

value of 0.

Step 10. To test the buttons, select Test Mode from the Touch menu

and click the button with the mouse.

Example: Create a Multistate Button with Attribute Changes

Step 1. Select New from the File menu.

Step 2. Define a button using the procedure outlined in the example

in section 3.4.8.

Step 3. Select Normal as the button attribute.

Step 4. Select Button Label and enter: 1

Step 5. Select Host Response and enter: 1

Step 6. Select the Graphic box from the Local Response Capture

List.
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Step 7. Click the Capture button.

Step 8. Select the Circle graphic from the Graphics Palette and

define a circle on the Design Window by clicking the mouse

pointer at the intended center of the circle and drag the

mouse until the desired size is achieved.

Note: We recommend that display lists be used to call up

graphics. If the target unit does not possess an

EPROM feature, you can imbed graphics within

button responses as in this example.

Step 9. Click the Exit button in the Exit Capture window.

Step 10. Click the Next button at the top of the Define Button

Response window. Note that the button state has changed

from 0 to 1 and all labels and responses have been cleared.

Step 11. Click the down arrow for Button Attribute and select

Highlight.

Step 12. Select Button Label and enter: 2

Step 13. Select Host Response and enter: 2

Step 14. Select the Pop-up Menu box from the Local Response

Capture List.

Step 15. Click the Capture button.

Step 16. Enter a value of 1 for the Page Number and click the OK

button.

Step 17. Select the Pop-up Menu Item and enter the word: Popup1.

Click the Add button.

Step 18. Select the Pop-up Menu Item and enter the word: Popup2.

Click the Add button.

Step 19. Select the x position dialog box and enter a value of 10



Deeco� Systems Touch Assist II

Page 53

Step 20. Select the y position dialog box and enter a value of 10.

Step 21. Select the Space box and enter a value of 1.

Step 22. Double click the word Popup1 within the main dialog box.

Step 23. Select Host Response and enter: Popup1. Click the OK

button.

Step 24 Double click the word Popup2 within the main dialog box.

Step 25. Select Host Response and enter: Popup2. Click the OK

button.

Step 26. Click the OK button within the Create Pop-up Menu

window.

Step 27. Click the Next button at the top of the Define Button

Response window.

Step 28. Click the Button Attribute down arrow and select: Vertical

Hatch.

Step 29. Select Button Label and enter: 3

Step 30. Select Host Response and enter: 3

Step 31. Select the Page box from the Local Response Capture List.

Step 32. Click the Capture button.

Step 33. Enter a value of 4 for the Page Number and click the OK

button.

Step 34. Click the Exit button in the Define Button Response

window.

Step 35. Click the Page Change slide switch found on the Status

Line until Page 4 is displayed in the Design Window title

bar.
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Step 36. Select the Place Button icon from the Function Palette and

double click the button with the mouse.

Step 37. Select Template and define a button with a dimension of 50

pixels by 50 pixels. Click the OK button.

Step 38. Click one square from the grid located within the Assign

Button Location dialog box. Click the Exit button.

Step 39. Double click the button image.

Step 40. Select Button Label and enter: Return

Step 41. Select the Page box from the Local Response Capture List.

Step 42. Click the Capture button.

Step 43. Enter a value of 0 for the Page Number and click the OK

button.

Step 44. Click the Exit button in the Define Button Response

window.

Step 45. To test the buttons, select Test Mode from the Button menu

and click the button with the mouse.

Note: When in Test Mode, the pop-up will be located at

the upper left hand corner of the Design Window.

Upon downloading this file to the target unit, the

pop-up will be positioned correctly according to

their defined positions.
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4.1.3 Pop-Up Menus

Pop-up menus are touch elements which mimic the Windows style pull

down menus. Capture Pop-up embeds the necessary command to

initiate a Pop-up. The Pop-up itself is defined by a user selected page

number and a sequence of pop-up elements (the items of the pop-up).

To conserve memory and avoid terminal operational difficulties;

ALWAYS SELECT THE LOWEST UNUSED PAGE TO DISPLAY

THE POP-UP MENU. See examples section for a more detailed

explanation. Capture will invoke a dialog box to specify the page

number and then a dialog box to define the pop-up elements.

A pop-up item is added to the list of items by entering the text of the

item as it will appear on the target screen and clicking the Add button.

The host message and local response of each pop-up item are specified

in an abbreviated response dialog box entered by double clicking an

item. The pop-up response box is similar to the button response box

without the label field edit feature.
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5.0 Test Mode

The application generated in a TAII session may be tested by

downloading it to the target unit. The communication link is specified

from the "Communication" item of the "Config" menu. Once

communication has been established, the application may be

downloaded to the target unit. This is done through the "download"

item of the Output menu. The TAII application is translated into the
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proper command sequence for the target and the download is initiated.

The actual downloaded command stream may be inspected using the

"View" item of the File menu. When the download is complete testing

of the application may occur.

To download and test a TAII design, the target product must be

connected to the PC serially. The serial link between the PC COM

port and the target must be defined correctly. The serial link is

defined using the "Communication" item on the "Config" menu. The

necessary specifications include which COM port (1 or 2), the baud

rate, the data format, and the parity selection. LCSP products

generally use a default communication standard of 9600 baud, 8 data

bits, 1 stop bit, and no parity.

The level of testing which is achievable depends on how the target is to

be used in a larger system and how much of that system is available

during the test. At a minimum, the local responses of the button

menus and button menu coupling can be tested. Using the Host

Window of TAII, the host messages may also be verified during

testing. Only the target and the PC are needed for this level of test.
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6.0 Application Integration

Once the application has been found to meet certain minimum

functionality goals, it may be incorporated into the host system. The

menus, graphics, and display lists resulting from the design may be

included in the software of the host, or if the application has been

carefully designed to make full use of display lists, it may be

downloaded into the non-volatile memory option of the target.

Regardless of where the application physically resides, it must be

invoked at system initialization. System initialization is typically a

power-up of all system components. If the application information is

resident in the host, it may be downloaded from the host to the target

at the host's convenience. If the application is pre-loaded into the

target's non-volatile memory in the form of a display list, the unit can

be configured to automatically invoke the lists and self-initialize.

Most LCSP products which offer display lists also offer the ability to

automatically execute a list upon power-up. This auto-configure

feature is usually accessible from the set-up function of the device.

List ID 0 is usually reserved for auto-configure. If an application is

structured so that it is partitioned into lists, and list 0 is dedicated to

controlling an initialization then the application may be embedded

within the non-volatile memory option of the LCSP product and auto-

configure may be used to invoke the application. See examples section

of manual.

Two other means of generating a usable form of a TAII design exist.

The "Output" menu allows a TAII design to be translated into a

command stream and placed in a file. The file can be unformatted

and can be used at run-time as input to a host software system and

downloaded to the target by the host when appropriate. The Output

menu can also produce a file encoded in a computer language. This

form allows the file to be added to the host system software at

compile-time. The user may choose from ASCII, COBAL, or

ASSEMBLY language. To run Touch Assist II, select Run... from the

File menu of the Program Manager. Enter the complete path for the

file TOUCH.EXE. Choose OK to start the application.
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You will see the Touch Assist II opening screen. At this point Touch

Assist attempts to use the COM 2 serial port for communication with

a LCSP target product. If this port is currently used for another

function or is otherwise unavailable an error message will be

displayed. Choose OK to continue Touch Assist II and select

Communications on the Config menu to select the proper COM port

for the target. If no target will be used the error may be ignored.
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