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Touch Assist IV User Manual

1.0 Overview

Touch Assist IV is a color mode touch interface software development tool for Deeco terminal
products. Deeco terminals use a special language to create graphics and touch areas like circles,
arcs, vectors, and touch buttons on the screen. Touch Assist IV translates visual representation of
the desired screen image and touch button operations into the Deeco command language. This
unique capability can dramatically reduce the time needed to write application programs.

2.0 Installation

Touch Assist IV is supplied on a single floppy disk and is comprised of three files:

1) INSTALL.EXE
2) TOUCH ASSIST IV.ZIP
3) README.TXT

To install TOUCH ASSIST IV to your hard disk, place the installing disk into your floppy drive
(usually A drive) and enter “A:INSTALL” at the MS-DOS prompt. The decompression program
on the disk will begin, and you will be told what to do at each step of the unpacking process until
all files are copied to the hard disk. You will need at least 4 MB of space on your hard drive for
the files.

2.1  Starting the Touch Assist IV

To run TOUCH ASSIST 1V, click the Start button from Task Bar and select the Run option, then
the Run dialog box will appear. Enter the complete path with the file name TA41. EXE. Choose
the OK button to start the application.
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3.0 New In This Version

This manual highlight some of the new and enhanced features and the performance improvement
for TOUCH ASSIST IV.

¢ Supports the C9 color terminals

2) Allows for Downloading Bitmap

€)) Add Font Editor

4) Additional Fill Patterns (10 patterns)

(5) Enhancements to User Interface

6) Additional features in graphic attributes (color)

(7 Alpha character attributes (color, italic, underline, reverse)
(8) New improvements with Online Help

© Support Plug & Play (auto detect comm port)
(10) Additional touch attributes (color)

System Configuration

TOUCH ASSIST IV will load the pre-selected Deeco serial terminal, and the communication
protocol. Upon running, TOUCH ASSIST IV will search the available COM ports automatically
and assign to the host communication. If there are no pre-selected parameters, the default settings
will be used. The defaults are the C9 as the default terminal, communication protocol is 9600
baud (if com port is available), 8 data bits, no parity, 1 stop bit and all the control signals such as
RTS/CTS, XON/XOFF, DSR/DTR are all on.

4.0 Overview

TOUCH ASSIST 1V is a Microsoftd] Windows950 based application. It only can run under
Windows95 and Windows NT. It is the next generation of application generating software for
Deeco touch/graphic serial terminals. These products are intelligent flat panel controllers married
with infrared touch sensing arrays. TOUCH ASSIST IV will help you to generate graphic screen
images and construct touch menu systems for use in Deeco serial terminals.

TOUCH ASSIST 1V is intended to aid the application and OEM designer in incorporating Deeco
products into their systems. It provides an easy-to-use graphical interface to the features and
functions of the Deeco product family. TOUCH ASSIST IV is a screen generator, a CAD tool
and a paint program whose output is easily embedded within the Deeco products.
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4.1  Deeco Touch/Graphic Serial Terminals

Deeco serial terminals are intelligent controllers for flat panel touch systems. The system of flat
panel, infrared touch, and controller is designed as a stand-alone ASCII/graphics terminal.

4.2  Touch Capability

The touch system, offered on all Deeco serial terminals, extends the terminal functionality and
creates a simple, powerful man-machine interface. Touch input can be as simple as X, Y
coordinate pair reporting. When you touch the screen, the coordinates describing the position of
the touch are reported to the host over the communication link. The Deeco serial terminal offers
this and more. You may define regions on the screen which represent actuators (buttons). When
a button is touched, the terminal may be programmed to take action independent of the host. That
is, you may embed commands in the definition of the button freeing the host of wasteful overhead.
The touch capability, as part of the Deeco serial terminal, is intended to provide a user-friendly
input device. The flexibility and simplicity-of-use makes this type of input device the most
attractive.

4.3  Buttons and Pages

The "button” is the basic touch unit in the intelligent touch system. A button is defined by its
position, shape and size on the screen, its visual appearance, and its response. Many buttons may
be grouped together to form a page (menu).

The button response, which is activated by touching the button, is divided into two parts, the local
response and the host message. The host message is an ASCII string which is sent to the host over
the communication link. The local response is an ASCII string which is treated like a host
command stream: it may contain any command which the host itself could send to the terminal.

It is the local response which represents the embedded intelligence of the touch system.

A page, or menu, is a group of buttons. A page may be identified by a single number (the page
number). When activated by a command, a page is automatically drawn on the screen. Pages
may be linked in a hierarchical structure by embedding the command to activate another page in
the local response of a button on the currently active page.
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4.4  Graphics Capability

The terminal functionality is based on Digital Equipment Corporation's popular VT series
(VT100, VT220, VT320, etc.). The VT series is the originator and prime user of the ANSI 3.64
standard command language for text terminals. The text terminal emulation is accurate and
reliable for these products. Some offer more complete emulations but all offer accuracy in the
subset of the VTxxx commands that they support. They support multiple visual pages, multiple
character sets, user-definable characters, editing functions, and extensive cursor control.

The graphics functions in Deeco serial terminals are accessed through an extension of the VTxxx
command structure. Basic graphic objects such as vector, circle, arc, and graphic text are
supported as well as advanced functions controlling coordinate transformation, clipping, and
windowing.

4.5  Color Palette

The Color Palette allows you to choose from 16 available color maps. You can customize the
colors used for the graphic objects and buttons in the TOUCH ASSIST IV design window, the area
of screen, foreground (pen, text) colors and background (fill, screen) colors. See graphic objects
and button attributes for detail. During power-up, TOUCH ASSIST IV will assign the black color
as the default screen color , the white color as the default pen color.

5.0 Touch Assist IV Design Tools

TOUCH ASSIST IV offers the interface designer a variety of tools to build the visual and tactile
interface like building button pages, linking pages, and designing associated graphic images.
TOUCH ASSIST IV uses function toolbars, color palettes, on-line help, and download functions to
aid the design process. The final output of TOUCH ASSIST IV can be transferred directly to a
Deeco serial terminal. Some Windows techniques used in TOUCH ASSIST IV and described in
this manual such as "clicking", "double clicking", and "dragging" are essential in the use and
understanding of TOUCH ASSIST IV. Descriptions of these techniques and others may be found

in the Windows manual.

The TOUCH ASSIST IV is composed primarily of four tool types:

1) System configuration and control
2) Target configuration and control
3) Graphics generation

4) Touch menu generation.
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The access to these tools is from the Menu Bar and the Function Toolbars. TOUCH ASSIST IV
layout consists of the following major components on the PC monitor:

Title Bar

This is a standard Windows item that displays the file name of the last TOUCH ASSIST 1V file
opened or accessed. It also has the standard Windows control bar and min/max controls.

Design Window

This is where the visual touch/graphics design is displayed as it is built.

Menu Bar

This is a standard Windows item which gives access to pull down menus that control the
configuration of the system, the target terminal, and other TOUCH ASSIST IV features and
functions.

Function Toolbars

An icon based front end to TOUCH ASSIST IV design tools.

Status Bar

This is where target terminal, system information and context sensitive help are displayed.

Host Response Status Bar

This is where the host information are displayed .

51 Title Bar

T Untitled - Touch Assist 95 EEE|

The title bar, a standard Windows characteristic, displays the program title (Touch Assist IV) and
more importantly the name of the active session, (the file name selected). The active session is
named after the file used for default file operations. If there is no default file, the session is
named "untitled". The default file name is set whenever a file is opened or saved. These
operations are accessed through the File menu selection. Specifying the New option from File
menu resets the default file to none.
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5.2  Design Window

The Design Window is where graphic images and touch menus are drawn and laid out. It
represents a portion or all of the physical screen of the Deeco serial terminal.

Undstind - 1 puch Aaanl 4 i (2l
Fia il Yww Joxn Fagn Lal [orfg Quiid Heip

Dlslas ezl || T

[Frasie Fagall  [HStAE#R) [wan v [ |
|t Raapainie |

The portion of the physical screen which is viewed may be changed (if necessary) by the scroll
bars on the bottom and side of the design window. The target serial terminal and the current touch
page are identified in the status bar. The page number is selected either from the function toolbars
or menu bar. The serial terminal type is selected from the Module option of Config menu. The
terminal type defines the screen size and the number of available pages.

5.3 Menu Bar

File Edt “iew Touch Page List Confip Output  Help

The Menu Bar consists of nine pull down menus: File, Edit, View, Touch, Page, List, Config,
Output, and Help. Standard Windows keyboard accelerator techniques allow the menus to be
activated by typing a letter as well as by mouse activation.
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5.3.1 File

The File menu is used to save and retrieve sessions. A session is an instance of running TOUCH
ASSIST IV and designing touch menus and graphics. Sessions may be saved, retrieved, and
combined. Many of the file operations available on the File menu conform to standard Windows.
Beyond the obvious file operation, some file menu items impact modes or other functions in
TOUCH ASSIST IV, or provide additional capabilities.

Mew Chrl+r
Open ...  Crl+0
Save Chil+5
Save bz F12
Wiew. .. Chl+af
Sppend...  Crrl+D
Delete ...  Del

E st

5.3.2 New File

The New option clears all defined objects from the session. All graphic objects, button menus,
and list references are erased.

Example: Creating a new file

Step 1. Select the New option from File menu. The Save dialog box will appear to prompt you to
save current modified active file.

Step 2. At this point you may create graphics or buttons in the design window.
Step 3. Select the Save As option from File menu, the SaveAs dialog box appears.

Step 4. Enter the file name and click the Save button.
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5.3.3 Open File

The Open option is used to retrieve an existing session file. File names are prompted for in the
dialog box associated with these functions. The selected file name becomes the session name
appearing in the TOUCH ASSIST IV title bar. Many touch modes are reset to the values which
have been assigned to the selected file. See Options option from Touch menu for detail.
Example: Opening an Existing File

Step 1. Select the Open option from File menu. The Save dialog box will appear to prompt you
to save current modified active file.

Step 2. Select the desired file from the choices presented in the Open dialog box.
Step 3.  Click the Openr button to open the selected file or click the Cancel button to abort the

Pprocess.

5.3.4 Save File

The Save option is used to save the file currently being worked on to it’s existing file name. A file
may be saved at any time after it is opened.

Example: Saving an Active File
Step 1. Follow steps 1-3 from the example of opening an existing file.
Step 2. Edit the opened active file.

Step 3. Select the Save option from File menu.
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5.3.5 SaveAs File

The SaveAs option is used to save the file currently being worked on to it’s existing file name or
to a new file name. The original file will still exist under the original file name. This is a useful
tool that will allow you to test different modifications while leaving the original intact.
Example: Saving an Active File under Different Name

Step 1. Follow steps 1-3 from the example of opening an existing file.

Step 2. Select the SaveAs option from File menu.

Step 3. Enter the new file name in the SaveAs File dialog box.

Step 4. Click the Save button or click the Cancel button to abort the process.

5.3.6 View File

The View option is used to examine the text information in any given file created during a session.
The desired file must be converted to an ASCII file before it can be viewed. See Qutput menu for
detail.

Example: Viewing a Text File

Step 1. Select the View option from File menu, the View File dialog box appears.

Step 2. Select the desired text file to be viewed.

Step 3. Click the Open button to display the text file.

Step 4. Click the OK button to exit the t View File dialog box.
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5.3.7 Append File

The Append option is used to combine sessions. The file specified in the appending operation is
combined with the current session. Appending does not change the session name. When
appending session, buttons on pages are combined and care must be taken if buttons overlap.
Another possible problem encountered is references to files as display lists. When the current
session and the appended session both name a file as a particular display list, the appended files
reference stands as the one used from then on.

Example: Using the Append Function to Combine a File

Step 1. Open the desired file to be appended using procedures discussed in the opening a file
example.

Step 2. Select the Append option from File menu the Append File dialog box appears.
Step 3. Select the target file from the dialog box.

Step 4. Click the Open button to combine the files or click the Cancel button to abort the
process.

Step 5. The first file will now be combined under the heading of the target file that was selected.

5.3.8 Delete File

The Delete option is used to delete any given file found under the TOUCH ASSIST IV directory.
All information associated to the file will be lost.

Example: Deleting a File
Step 1. Select the Delete option from File menu. The Delete File dialog box appears.
Step 2. Select the desired file to be deleted from the dialog box.

Step 3. Click the Open button to delete the selected file or click the Cancel button to abort the
process.

10
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5.3.9 Exit Touch Assist IV

The Exit option allows you to exit TOUCH ASSIST IV program and return to Windows95. If the
current active file has been modified, the Save dialog box will appear to prompt you to save it.

Example: Exiting from Touch Assist 1V.

Step 1. Select the Exit option from File menu.

Step 2. At this point a dialog box will prompt you to save file.

Step 3. Clicking the OK button will save the file prior to exiting TOUCH ASSIST IV. Clicking

the Cancel button will exit TOUCH ASSIST IV without saving the changes made to the
current active file.

5.3.10 Edit

The Edit menu provides some basics of editing within pages in TOUCH ASSIST IV design
window.

Cut Chrl+
Copy Chrl+C
Paste Chrl+f
Select Al

5.3.11 Cut

See Function Toolbars for detail.

5.3.12 Copy

See Function Toolbars for detail.

5.3.13 Paste

See Function Toolbars for detail.

11
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5.3.14 Select All

The Select All option can be used to select/deselect all the graphic objects and buttons of current
displaying page in the design window.

5.3.15 View

The View menu changes the look and size of design window and menus as well as more.

v Toolbarz
v Statuz Bar

Page Clrl

5.3.16 Toolbars

The Toolbars contain function buttons that give you quick mouse access to many commands and
features. You can see the name of each toolbar button in a TeolTip. When you point to a button
with the mouse, the button name will appear in a box. The Toolbars option allows you to turn on
and off the Function Toolbars in the design window.

5.3.17 Status Bar

The Status Bar show information and messages at the bottom of the design window. It provides
the information about the mouse position, the current displaying page, the prompt text of the
command and the status of some important keys. The Status Bar option allows you to turn on and
off the Status Bar in the design window.

12
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5.3.18 Page

Unlike the design window however, a simulation of the entire screen of the target device is
shown. The Page option allows you to view the entire page. The buttons and graphic objects are
shown as they appear upon the Deeco serial terminal. This is a view only function. No changes
may be made (o the page.

Example: Activate View Page

Step 1. Select the Page option from View menu, the View Page window appears.

Step 2. Click the x box located at the upper right corner of the View Page window to return to
design window.

5.3.19 Touch

The Deeco serial terminal supports several basic types of touch reporting. The touch sensor
normally sends touch information, depending on which modes are active.

Ophions.  Chl+T

Print Page  Chl+G
Print Al Chrl+F

Test

13
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5.3.20 Options

Parameters which control touch application generation are accessed through this menu. The Deeco
serial terminal supports many modes of operation which change the look and feel of touch buttons
and menus as well as more rudimentary touch functionality. For detailed descriptions of these
modes, refer to the product manual of the device. Typically, the default values used by TOUCH
ASSIST IV are sufficient.

Example: Configuring Touch Button Report Modes.

Step 1. Select the Options option from Touch menu, the Touch Options dialog box appears.

— Touch Modes
¥ Ertre Repart [~ Track Repot [ Muliple Touch Repart
™ Exit Beport ™ Highlight Tauch I Enable Beep

I~ ANSI Response

— Button Modes
¥ Ensble [ Entrp/Exit ¥ Clear Screen on Page Change
¥ Auto-draw I¥ Enable Beep ¥ Highlight Touches

™ Zero Highlight and Border Disable [T Label Pack

_ Dt |
— Pop-Up Menus Ok, I
_Cercel |

Drefault

™ Hide Priimary Menu During Popllp Cancel

— KeyBoard Modes
™ Keyboard On ¥ Keyhoard Enabled

Step 2. Select the desired button report mode(s) from the choices provided. The marked box will
enable that mode.

Step 3. Click the OK button to save all the changes, click the Default button to use all the default
settings or click the Cancel button to abort the process.

14
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5.3.21 Print Page

The Print Page option prints the view offered by Page option from View menu.

Example: Printing a Page

Step 1. Open an existing file or created a new file using procedures discussed in the File menu.
Step 2. Select the page that you want to print.

Step 3. Select Print Page option from Touch menu. The current page in the design window will

be printed.

5.3.22 Print All

The Print All option prints the view offered by Summary option from Page menu.
Example: Printing All
Step 1. Open an existing file or created a new file using procedures discussed in the File menu.

Step 2. Select Print All option from Touch menu. All the pages which belong to the current
active file will be printed in a hierarchical structure view.
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5.3.23 Test

The application generated in a TOUCH ASSIST IV session may be tested before

downloading it to the attached Deeco serial terminal. You may view and change the result of all
the activities of each button at different page. This is a very helpful function to reorganize each
button page before downloading the application to the target terminal. The responses of the button
menus and button menu coupling can be tested. Using the Host Response Status Bar of TOUCH
ASSIST IV, the host messages may also be verified during testing.

Example: Using Test Mode

Step 1. Open an existing file or created a new file using procedures discussed in the File menu.

Step 2. Click the button to show the Host Response Status Bar.

Step 3. Select the Test option from Touch menu. All TOUCH ASSIST IV Menu Bar and
Function Toolbars are disabled while in test mode.

Step 4. Positioning the mouse onto a button image and clicking the left mouse button once
emulates activating the button. The host message will show on the host response status bar
and the local response will be executed.

Step 5. Select Test option from Touch menu to exit the test mode.

5.3.24 Page

The Page menu is used for viewing the contents of button pages. The current page is the button
page currently displayed and active for editing. TOUCH ASSIST IV always displays the contents
of the current page on the design window. All the defined graphic objects and buttons will be
saved into the current page. There are two ways to select a desired page. Using the function
toolbar page button to change to the Previous or Next page, or use the GoTo option from Page
menu to select any page.

GoTo.. Shift+
Summary... Chil+L
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5.3.25 GoTo

The GoTo option allows you to display any button page in the design window.
Example: Select a page using GoTo

Step 1. Select the GoTo option from Page menu, the Page dialog box appears.

(Page |
Select Page [0-119]: I'I|
ok I Cancel |

Step 2. Enter the page number 1.

Step 3. Click OK button to exit the Page dialog box. The design window will display the contents
of page 1 and Page 1 will be displayed in the Status Bar or click the Cancel button to
abort the process.

5.3.26 Summary

The Summary option allows you to view the current application in different ways. In this view,
all pages are shown in a hierarchical structure. Individual elements of the page, buttons and
graphic objects, are described. The structure can be expanded (click the + sign) and scrolled to
view all pages and their elements. The detailed specifications of individual buttons on a page can
also be viewed.

Example: Page Summary
Step 1. Open an existing file or created a new file using procedures discussed in the File menu.
Step 2. Select the Summary option from Page menu, the Page Summary dialog box appears.

You will be able to view the summary of the button pages which have been defined by the
current active file.

17
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Page Summary _________________________A|

L &l local:*[[<1x
E|E| Page 1
B Ellipse

Step 3. Click OK button to exit the Page Summary dialog box.

5.3.27 Display Lists

Display lists are a feature in the Deeco serial terminals. A display list is a sequence of commands
which are grouped together and may be referred to by a single numeric ID. They are used as
macro commands. In the terminal, these commands can be stored locally, often in non-volatile
memory, so that the host system can issue a single simple instruction to execute the entire
command macro. This saves on communication overhead and helps embed local intelligence and
flexibility in the target terminal. TOUCH ASSIST IV provides a means to define and use display
lists when designing applications.

In TOUCH ASSIST 1V, display lists can be used to couple graphics and touch menus. The action
(local response) of a button may invoke a display list. The list contents, graphic commands, are
executed resulting in graphic images on the screen. A local response may also contain a command
to change button pages. By doing both in a local response a button may change button pages and
efficiently draw its associated graphics. Buttons on many different pages may use the same local
response combination of page change and display list. See examples section to learn how to create
and use a display list.

18
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Define... Chl+F
Delete... Chrl+Del
Wiew .. Shift+w
Arrange

Save

5.3.28 Define List

Display lists are referenced as separate files in a TOUCH ASSIST IV design. These files typically
will contain frequently used graphics. In fact, a file referenced as a display list may contain
graphics, or graphics generated text. Attempting to reference a file which contains button menu
definitions as well will result in an error. To reference a file as a display list in a TOUCH
ASSIST 1V session, use the Define option from List menu. The dialog box invoked by this option
asks for the numeric ID of the list and the file to be referenced. The ID is then used throughout
TOUCH ASSIST IV to reference the display list.

Example: Creating a Display List
Step 1. Select the Define option from List menu, the Define Display List dialog box appears.

Define Display List I
|nput Dizplay Lizt Mumber ; ||
0k I Cancel |

Step 2. Enter any desired number from 1 to 255 into the Display List Number edit field. For this
example, input a value of 1.

Step 3. Click the OK button , the Select Display List File dialog box appears.
Step 4. Select the name of a new file which will associated with the display list number.

Step 5. Click the Open button to end the process.
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Step 6. At this point, the user has created a display list that can be accessed as part of a button
response whenever necessary. Refer to the section on Button Local Response for further
details.

5.3.29 Delete List

The Delete List option allows lists to be deleted. The deleted lists will not be downloaded or
otherwise specified in output file. References to deleted lists, such as in the local responses of
buttons, are not deleted. The Deeco serial terminals will correctly ignore references to non-
existent lists.

Example: Deleting a Display List

Step 1. Select the Delete option from List menu, the Delete Display List dialog box appears.
Step 2. Enter the number of the display list to be deleted into the Display List Number edit field.

Step 3. Click the OK button. This will cause the specified display list to be deleted from TOUCH
ASSIST IV, but the file which associated with the deleted display list is intact.

5.3.30 View List

The View option from List menu displays a graphical directory of all defined lists and the files
associated with the lists.

Example: Viewing Display List Summary
Step 1. Open an existing file containing display lists.

Step 2. Select the View option from the List menu. The View Display List Summary dialog box
appears.
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Yiew Dizplay List Summary

- Display Lizt

Select the dizplay list file to zee the contents

Cancel

Step 3. Click the + sign to expand the graphical directory. The vertical scroll bar located at the
right hand side of the dialog box allows you to advance the summary towards additional
lists as necessary.

Step 4. Select a display list and click the OK button , the View ASCII File dialog box appears. It
allows you to view the ASCII information contained within the selected display list.

Step 5. Click the OK button to exit the View ASCII File dialog box.

5.3.31 Arrange and Save List

This modal functions are useful in formatting various touch and graphic objects in the design
window. During in the test mode, if a display list has been assigned to a button as a local response
capture, at this point, TOUCH ASSIST IV allows you to rearrange the position of each graphic
object in order to align with the button.

Example: Using Arrange/Save List in Test mode
Step 1. Open an existing file containing display lists.
Step 2. Select the Test option from Touch menu.
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Step 3. Select the Arrange option from List menu. The Select Display List dialog box appears.

Step 4. Select the display list and click the OK button. The contents of the selected display list
will be displayed on the design window.

Step 5. Select the graphic object and move to the desired location.
Step 6. Select the Save option from List menu to save all the changes.

Step 7. Select the Test option again to exit the test mode.
5.3.32 Config

Configuration refers to both the development system (the PC running TOUCH ASSIST IV under
Windows) and the target Deeco serial terminals.

Hezet Cil+R

Touch Module...  Chil+E

Communication...  Chrl+M

5.3.33 Reset Terminal

You can manually send a Reset command to the target terminal. When the Reset option is selected
from Config menu, the attached Deeco serial terminal connected to the serial port of PC will be
reset. All the graphic objects, button pages and display lists will be deleted. During downloading
file, The Reset command will be sent automatically by TOUCH ASSIST IV.

Example: Sending a Reset to the Target Terminal

Step 1. Select the Reset option from Config menu.

5.3.34 Touch Module

The Deeco serial terminal to be used as the target of a TOUCH ASSIST IV design is selected from
the Touch Module option. The Deeco serial terminals are identified by their controller model
number (C3, C4, C320, etc.). To select one, click the selection box near the name. The
selection of the target terminal implicitly selects the screen dimension and insures proper
translation of the TOUCH ASSIST IV design to output format.
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Example: Configuring Touch Assist IV for a specific module

Step 1. Select the Touch Module option from Config menu, the Select Module dialog box

appears.
| SelectModule |
ol o [ -]

g ol T R

Carnicel |

Step 2. Select the appropriate terminal. Refer to the following list of compatible terminals by
category. Each selection can be toggled on and off by rechecking the same selection.

C320 (640x200/640x400): C4 (640x400):
M320ST/M320ST-AC MA4ST
ST2200 ST3220
ST2200XT ST3225
ST2205 ST3420
ST2400

C3 (512x256): C9 (640x480):
M3 MOST

M3-15 ST4500

Step 3. Click the OK button to activated the configuration or click the Cancel button to abort the
selection.

23



Touch Assist IV User Manual

5.3.35 Communication

To download and test a TOUCH ASSIST IV design, the target terminal must be connected to the
PC serially. The serial link and data transfer formatting between the PC COM port and the target
terminal must be defined correctly. The serial link, and data transfer formatting are defined using
the Communication option from Config menu. (The default settings are 9600 Baud, 8 Data Bits,
1 Stop Bit and No Parity, the control signals such as XON/XOFF, RTS/CTS, DTR/DSR are all
on)

Example: Setting Communication Port Settings

Step 1. Select the Communication option from Config menu, the Comm Port Configuration
dialog box appears.

Com Port Configuration I

— COM Options ————— Flow
v HONA<OFF
o [ETm=] || ¥
¥ RTS/CTS

B aud Fiate: IE‘EE":' :Iv ¥ OTR/DSE

[ ata Bits: IE 'I

Prarity: INl:une 'I

Stop Bits: |‘| vI |
Cancel

Step 2. Select the appropriate configuration selections. For details regarding communication
requirements, refer to the Applications manual for the specific terminal.

Step 3. Click the OK button to activate the selected communications settings or click the Cancel
button to abort the settings.

5.3.36 Output

The Qutput menu allows you to convert file into various output forms. The output file can be used
in alternate programming mode such as Assembly Language and C Language.
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Settings... Shift+5
Download Chrl+L

ASC File Shift+l

A5k Data Format Shift+d,
C Data Format Shift+C
Send Cornmand to... Shift+0
Send test file to.. Shift+T

5.3.37 Settings

During downloading an active file to the attached Deeco serial terminal or output file, TOUCH
ASSIST IV will prompt you a list of conditions which will be activated. You can select the

appropriate conditions for the downloading.

Set Output File Parameters

Dwaring dowenloading file, doyou want to

[+ Clear All Buttons
[+ Clear All Display Lists

[T Define 0x80 to 0x9F are contral characters

[ Config for Autoexec of List 0
[T Execute Display List 1

Ok

Cancel

5.3.38 Clear Screen

This option will command the attached Deeco serial terminal to clear the information displaying

on the design window.

5.3.39 Clear All Buttons

This option will command the attached Deeco serial terminal to release all the system memory
reserved for the buttons storage.



Touch Assist IV User Manual

5.3.40 Clear All Display Lists

This option will command the attached Deeco serial terminal to release all the auxiliary memory
reserved for the display lists storage.

5.3.41 Define 0x80 to ox9F Are Control Characters

This option will command the attached Deeco serial terminal to treat the characters range from
0x80 to 0x9F either as displaying characters or control characters.

5.3.42 Config for Autoexec of List O

This option will command the attached Deeco serial terminal to save all the received command
sequences into display list 0. The display list 0 will be executed automatically by the serial
terminal after powering up.

5.3.43 Execute Display List 1

This option will command the attached Deeco serial terminal to execute display list 1.

Example: Change the Downloading Settings

Step 1. Select the Settings option from Qutput menu, the Set Quiput File Parameters dialog box
appears. At this time you will be prompted with a list of conditions to be activated during

downloading. Select the appropriate conditions for the downloading.

Step 2. Click the OK button to save the options or click Cancel button to abort the process.
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5.3.44 Download

The Download option is used to transfer files to the attached Deeco serial terminal. TOUCH
ASSIST IV translates the data files into appropriate command sequences as it downloads over the
serial link. Once communication has been established, the application may be downloaded to the
target terminal. The actual downloaded command sequences stream may be inspected using View
option from File menu.

Example: Downloading a File to Target Terminal

Step 1. Follow steps 1-3 from the example of opening an existing file.

Step 2. Select the Download option from Qutput menu. The active file and the settings will all be
downloaded at this time.

5.3.45 ASCII File

The ASCII File option allows you to convert the active file shown in the design window into
ASCII format file. You can use the Send Text File To option to download this ASCII file to target
terminal.

Example: Outputting ASCII File

Step 1. Follow steps 1-3 from the example of opening an existing file.

Step 2. Select the ASCII File option from Qutput menu.

Step 3. The ASCII formatted file is viewable using the View option from File menu.

5.3.46 ASM Data Format

The ASM Data Format option allows you to convert the active file in the design window into
Assembly language format file (with the ASM extension). This is not a compiled file, it is a co-
generated file with a format change. You can paste the file into your programming application.
Example: Outputting ASM Data Format

Step 1. Follow steps 1-3 from the example of opening an existing file.

Step 2. Select the ASM Data Format option from Qutput menu.
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5.3.47 C Data Format

The C Data Format option allows you to convert the active file in the design window into C
language format file (with the C extension). This is not a compiled file, it is a co-generated file
with a format change. You can paste the file into your programming application.

Example: Outputting C Data Format

Step 1. Follow steps 1-3 from the example of opening an existing file.

Step 2. Select the C Data Format option from Qutput menu.
5.3.48 Send Command To

The Send Command To option allows you to send any command to the attached Deeco serial
terminal for any operating information such as ask for the results of self-test, get/set touch modes,
activate a display list and so on. The results of these inquiries will be reported by the terminal and
displayed in the Host Response Status Bar.

Example: Sending a Command to Target Terminal

Step 1. Select the Serd Command To option from Qutput menu, the Send Command To
Terminal dialog box appears.

Step 2. Enter the command string into the edit field. You can enter the ANSI symbols (CSI,
DCS, ST) into the command string.

Step 3. Click the OK button to send command to the attached serial terminal or click the Cancel
button to abort the process.
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5.3.49 Send Text File To

The Send Text File To option allows you to send any ASCII file to the attached Deeco serial
terminal.

Example: Sending a Text File to Target Terminal

Step 1. Select the Send Text File To option from Qutput menu, the Send Text File dialog box
appears.

Step 2. Select the ASCII file.

Step 3. Click the Open button to send file to the attached serial terminal or click the Cancel
button to abort the process.

5.3.50 Help

TOUCH ASSIST IV utilizes a standard Windows help facility. An index is provided for common
TOUCH ASSIST IV procedures and concepts. The index is accessed via the Help Topics option.
To get help on Windows help facility, use the Help Contents option.

Help Topicz
Help Contentz  F1

About TAT5

5.3.51 Help Topics

The Help Topics option allows you to search in help for information related to topics on which
you want more information. You can type the topic or select it from the list in the Search dialog
box and then click the Display button to see the detail.
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5.3.52 Help Contents

The Help Contents option will display the contents of TOUCH ASSIST IV system, step-by-step
instructions and examples.

Example: Using Help Contents

Step 1. Select the Help Contents option from Help menu.

Step 2. Position the mouse pointer on the desired subject of inquiry.
Step 3. Click the left button on the mouse.

Step 4. Follow instructions on the screen.

5.3.53 About TOUCH ASSIST IV

The About TOUCH ASSIST IV option will display information about your copy of Touch Assist
IV, including the version number, the copyright, and the system information for your computer.

54 The Function Toolbars

[0 | | o | B2 B8 Fr |50 50| B
Al 2 AN ol |o|c|B = o] 2| E

The tools represented by the Function Toolbars icons allow the creation and manipulation of touch
buttons and pages, and the manipulation of graphics and text. These toolbars hold all the graphic
edit functionality such as cut and paste, move, re-size, and delete as well as the button definition
functionality.

Items on the toolbars are selected by moving the cursor to them and clicking. Some functions,
such as the edit functions are modal; that is, they are a mode of operation and the mode continues
until another function is selected. Functions such as button creation are not modal; they cause an
immediate action. The significance of modal functions is that they inhibit non-modal functions
and graphic draw operations. It is not possible to draw graphics in the design window during a
modal operation. The meaning and function of the mouse cursor in the design window is tied to
the modal operation in effect. Modal functions are terminated by selection of another function.
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5.4.1 New, Open and Save

See File menu from Menu Bar for detail.

5.4.2 Cut, Copy and Paste

Cut and Copy work together with Paste to allow the movement of graphic objects and buttons
from one page to another. They are modal operations and will be in affect until another function
is selected. Typically the other function will be Paste. Cut and Copy only differ in how the
source objects are treated in the ensuing Paste operation. If the objects are cut, they will be
deleted when the paste happens, if they are copied, they will remain unaffected by the paste. The
following description of the cut operation pertains to copy as well, except for the behavior noted.

An item or group of items is selected during a cut operation by creating a cut area. The cut area
is a rectangular region encompassing all the desired items. An item must be fully contained within
the cut area to be affected. The cut area is created by moving the mouse cursor to the top left of
the desired region, pressing the left mouse button, and dragging the mouse (moving it with the
button depressed) diagonally to the lower right corner of the desired region. The cut area will be
identified by a dotted rectangle which rubber-bands as the mouse is dragged.

The cut area will be removed from the screen (cut) when the paste operation has been selected and
performed. To paste, select the page where the item is to be pasted then select the Paste function
from the function toolbars. The objects within the cut area will be positioned on the new page at
the same relative coordinates as they held on the original page. They can be moved, if desired, to
a new relative position by using the move function.

Example: Cut and Paste Function

Step 1. Select the New option from File menu.

Step 2. Define a circle on the design window as described in the circle example.

Step 3. Click button from the function toolbars.

Step 4. Place the mouse pointer at a point above and to the left of the circle. Click and drag the
mouse until a dotted box fully encloses the circle.

Step 5. Click the button from function toolbars. The circle within the cut area disappears.

Step 6. Click the 7] button on the function toolbars. This will change the design window to a
new page. The current page number is displayed in the status bar.
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Step 7. Click the button from function toolbars the circle appears at the new page.
Example: Copy and Paste Function

Unlike the cut function, the copy function will leave the original objects intact. Be careful when
copying buttons. Some buttons' local response such as popup might required modification to be
compatible with their new location.

Step 1  Select the New option from File menu.

Step 2. Define a circle on the design window as described in the circle example.

Step 3. Click button from the function toolbars.

Step 4. Place the mouse pointer at a point above and to the left of the circle. Click and drag the
mouse until a dotted box fully encloses the circle.

Step 5. Click the button from function toolbars.

Step 6. Click the 7] button on the function toolbars. This will change the design window to a
new page. The current page number is displayed in the status bar.

Step 7. Click the button from function toolbars.
The circle will appear at the new page.

5.4.3 Font Editor

With Font Editor, you can modify an existing font file to create a new font file for the application.
TOUCH ASSIST IV supplies 4 template font files with font editor which are font.fO8(8x8),
font.f14(8x14), font.f16(8x16) and font.f19(8x19). Based on the selected Deeco serial terminal,
the correct template font file will be loaded automatically during the initial of font editor.
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5.4.4 Working Area

Font Editor provides the working area where the font data will be loaded into and edited. The
displaying points of the width and height of the font data are represented by each rectangle, click
each rectangle will set/clear each point. There are dark circle located around the working area,
click each dark circle will set/clear each row or column of the points. Also, there is a rectangle
located at the top left corner of the working area, click this rectangle will set/clear the whole
working area. Font Editor gives a special term of the above three control locations which are
called control points.

5.4.5 Bit Operations

There have three bit operations which you can use to set/clear the control points in the working
area during edit the font character.

1) XOR bit manipulation: Under this mode, clicking the control points in the working area
always toggles the points.

2) SET bit manipulation: Under this mode, clicking the control points in the working area
always sets the points.

3) CLEAR bit manipulation: Under this mode, clicking the control points in the working
area always clears the points.
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5.4.6 How to Create a Font File
Step 1. Click the E button from function toolbars, the font editor dialog box appears.
font.f19 - Font Editr |
Character : ix@ | Font Size: 8x19 FI‘:F
OS99 9
: Bit Operation
-4 " ®OR ¢ Clear % Set
H
L ]
M Boovezre-gogs
L ]
: KN 2]
L ]
L ]
L ]
H
: Help |
Savebs Download Load | E it |

Step 2.

Step 3.

Step 4.
Step 5.
Step 6.
Step 7.
Step 8.

Step 9.

Click the Load button to load an existing font file or use the current template font file to
build a new font file.

Using the scrollbar to select the font character. The selected font character will be loaded
into the working area.

Select the bit operation.

Click the control points to edit the font characters.
Click Save or SaveAs button to save the new font file.
Click the Download button to download the font file.
Click the Exit button to exit the font editor dialog box.

Use Send Command To option from Output menu to test the new font file.
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5.4.7 Screen Color

The Screen Color function allows you to set the desired screen color of the design window if the
current selected Deeco serial terminal is C9.

Example: Set Screen Color

Step 1. Click button from the function toolbars, the Palette dialog box appears.

Step 2. Click the color button from the Palette dialog box. At this time, the screen color of the
design window will be replaced with the new color.

5.4.8 Grid Lines

Grid lines is a useful visual tool for aligning buttons and graphics in the design window. The =]
button is a toggle button to turn on and off the grid lines. The current selected pen color will be
used to draw the grid lines.

5.4.9 Host

The Host function refers to an additional window located under the Status Bar, the Host Response
Status Bar, which can be displayed on the screen. The status line displays information which is
transmitted from the attached Deeco serial terminal connected to the COM port of the PC. The
host function toggles the displays of the Host Response Status Bar.

Example: Using the Host Function

Step 1. Select the New option from File menu.

Step 2. Click button from the function toolbars. The Host Response Status Bar appears at
the bottom of the window.

Step 3. Create a button as described in button example.
Step 4. Select Test option from Touch menu.

Step 5. Click the button located within the design window with the mouse pointer. You will
notice the host response within the Host Response Status Bar.

Step 6. Select Test option from Touch menu to exit the test mode.
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5.4.10 Page Control

TOUCH ASSIST IV provides a quick and easy way to select adjacent page, so you don’t have to
go through the menu selection to change to the previous or next page.

Example: Select the adjacent page
Step 1. Click the E button to select the previous page.

Step 2. Click the m button to select the next page.

5.4.11 Alpha Character Control

TOUCH ASSIST IV allows you to change alpha controls such as alpha text color, attributes
(italic, underline, reverse video), size and character sets.

Example: Set the alpha character control

Step 1. Follow steps 1-3 to open an existing file.

Step 2. Click Al putton from the function toolbars, the Alpha Text Attribute dialog box appears.

36



Touch Assist IV User Manual

Alpha Text Attribute I

Character Size: & 1 € 2 € 3 € 4 ,
x T

Swle: [ Ejtalicﬁf I Undeiline ™ Feverse Video

Character Set: & Alpha zet ¢ User defined

Palette
(IIIIIIIEIIIDDIIDD

Text Palette :
Style
Text Background AaL 1PpHhAa
Reverze Text
Reverze Text Background fAaL IFpHhAa

F. I Cancel |

Step 3. Choose alpha text attributes and size.

Step 4. Click the OK button to confirm the changes or click the Cancel button to abort the
process.

Step 5. Download the active file to the attached Deeco serial terminal.

Step 6. Use Send Command To option from Qutput menu to send any text string to the target
terminal to see the result.

5.4.12 Pen and Fill

The pen and fill styles control the appearance of lines and region and are selectable from the
function toolbars. The line style controls the appearance of vectors, arc, polygon and circle
borders. TOUCH ASSIST IV totally supports 6 different line styles.

The fill style controls the appearance of filled regions. TOUCH ASSIST IV totally supports 10
different fill styles. The pen color will be used to draw the graphic object border and fill pattern.
The fill color will be used to fill the gap within the filled pattern. The current selections will be
displayed on the function toolbar (drawing tool attribute window). The Pen and Fill selections will
only affect the graphic images.
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Example: Setting the pen and fill style

Step 1. Select the New option from File menu.

Step 2. Click button from function toolbars, the fill/pen pattern tabbed dialog box appears.

Graphic Attribute E3
< Rl |7 Pen |

" Background Color

EEEREERCEmOOmECL

Fill Style :

o fill

zolid fill

wert il

harz fill

left slant hatch Al
tight glant hatch fill
zparze dot fill
wide left zlant il
wide right slant fill
diagaonal fill

crozz fil

I

HENZLNL

0k I Cancel Help

Step 3. Select the Vertical Fill option within Fill List Box.
The demo box located at the upper right corner of the dialog box will reflect the changes
of current graphic attributes.

Step 4. Click the Pen tab to show the Pen Style dialog box.

Step 5. Select the Solid Pen. In order for the shading option to function, the solid line style
option must be active.

Step 6. Click the OK button to end the selection. The drawing tool attribute window will display
the current selections.

Step 7. Create any graphic object on the design window to see the result.
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5.4.13 Graphic Text Attributes

It is possible to alter the visual appearance of text. The Font set, color, size, orientation, as well
as such attributes as underline, italics, and reverse video may be changed. String path, how
successive characters are placed relative to one another, may also be changed.

Example: Setting the graphic text attributes

Step 1. Select the New option from File menu.

Step 2. Click the button from the function toolbars, the Text Attribute dialog box appears.
Fonts are referred to by the Char Set. A character is scaled in Deeco serial terminals by
pixel replication. The size of the pixel is selectable as an integral multiplier of the base
pixel size. Orientation refers to character and string rotation, which is in multiples of 45
degrees. Path refers to successive character placement and may be left-to-right, bottom-
to-top, right-to-left, or top-to-bottom. Palette can be used to define the text foreground
and background color.

Graphic Text Attribute I
Char Fixel Size [1-18] : Text Orientatiorn : m

i [0 =
Stle: [ Italic [~ Undedine [~ Reverse Video
Fath: & L-R ¢ B-T ¢ R-L ' T-BE

Character Set: % Alphaset € User defined

Palette Style

HEERRNEO | TtEeXxTt
| (M [N TtEeXxTt

Text Palette :

Text Background

Hlite: T et

Hlite: T et B ackaround Cancel |
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Step 3.

Step 4.

Step 5.

Select the graphic text attributes, the demo box will reflect all the changes.

Click OK button to exit the dialog box or click Cancel button to abort the process.

Click ® button from the function toolbars to define a graphic text string with all the
new attributes.

5.4.14 Edit and Move

The edit and move modal functions are used to resize and reposition the graphic objects, and
buttons on the design window.

5.4.15 Resize

To resize an object, select the edit function and move the mouse cursor on the desired object and
click the left mouse button. The resize handles will appear at various points on the object. The
number of handles depends on the type of object selected. When the mouse cursor is placed on
any of these resize handles and the left button is pressed, dragging the mouse will resize the

object.

Example: Resize a object

Step 1.

Step 2.

Step 3.

Step 4.

Step 5.

Select the New option from File menu.

Define a rectangle as described in the rectangle example.

Click button from the function toolbars.

Place the mouse pointer within the area of the rectangle and click the left button. The
resize handles will appear on each corner of the rectangle.

Click and drag one of the resize handles to modify the size of the rectangle. Once the left
button of the mouse is released, the rectangle will be positioned at that new coordinate.
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5.4.16 Single Move

Single move modal operation is used to move a single graphic object or button on the design
window.

Moving object starts with identifying them. For single object moves, the object is selected by
moving the mouse cursor onto the object and pressing the left button. The object will be identified
by a displaying the resize handles. By dragging the mouse with the left button pressed, the object
can be repositioned to any desired location. Releasing the left mouse button will leave the moved
object permanently in their new position.

Example: Single Move Function

Step 1. Select the New option from File menu.

Step 2. Create a rectangle as described in the rectangle example.

Step 3. Click k==& button from the function toolbars.
Step 4. Place the mouse pointer within the area of the rectangle and click the left button.

Step 5. Click and drag the object with the mouse to the desired location. A dotted line
representation of the object will appear.

Step 6. Once the mouse button is released, the object will be positioned.
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5.4.17 Group Move

Group Move modal operation is used to move graphic objects and buttons on the design window.
Moving objects starts with identifying them. Groups of objects are selected by moving the cursor
to a point above and to the left of the items and pressing the left mouse button. By dragging the
mouse, a dashed box is created which can be used to encompass the desired objects. The mouse
cursor can be moved into the box and the left mouse button pressed . By dragging the mouse with
the left button pressed, the objects can be repositioned to any desired location. Releasing the left
mouse button will leave the moved objects permanently in their new position. When moving a
group of objects, only those contained entirely inside the dashed box will be moved. All other
objects will be left unchanged.

Example: Group Move Function

Step 1. Select the New option from File menu.

Step 2. Create two rectangles as described in the rectangle example.

Step 3. Click E==d button from the function toolbars.
Step 4. Place the mouse above and to the left of the region to be moved.

Step 5. Click and drag the mouse until a dotted rectangle encompasses the objects to be moved.
At this time, release the mouse button to define the region.

Step 6. Place the mouse pointer within the any selected objects.
Step 7. Click and drag the object with the mouse to the desired location.

Step 8. Once the mouse button is released, the objects will be positioned.
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5.4.18 Vectors

Two types of vectors are supported: random and orthogonal. Random vectors can be any
orientation. Orthogonal vectors are always parallel the X and Y axes. The methods for drawing
either vector type are the same, though the results will be different.

Example: Drawing a Vector

Step 1.

Step 2.

Step 3.

Step 4.

o e
Click button to select the pen style and color.

Click button from the function toolbars.

Move the mouse cursor in the design window to the desired start point, and click the left
mouse button.

Move the mouse to the desired end point and click the left button again to complete the
process or click the right mouse button to abort the process.

5.4.19 Arcs

Arcs are sections of circles and are defined by three points.

Example: Drawing an Arc

Step 1.
Step 2.

Step 3.

Step 4.

o e
Click button to select the pen style and color.
Click £ button from the function toolbars.

Move the mouse cursor to the desired positions and click the left mouse button. The first
position will define one end point of the arc.

Repeat Step 3 for points 2 and 3 of the arc. The second position will define the opposite

end point of the arc. The last position will define any given point on the curve of the arc
itself. The arc will be drawn upon the specification of the third point.
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5.4.20 Circles

Circles may be filled or unfilled. Unfilled circles will use the any line style for the border but
filled circles will always use a solid border.

Example: Drawing a Circle

"
Step 1. Click button to select the pen/fill style and color.

Step 2. Click 2 button from the function toolbars.

Step 3. Move the mouse to the center of the desired circle, press and hold down the left mouse
button.

Step 4. Drag the mouse with the left button held down. An ellipse with current pen style border
will appear and will move as the mouse is moved.

Step 5. Release the mouse button. The ellipse will become a circle with the selected attributes.

The radius of the resulting circle is always the minor (smaller) axis of the ellipse.

5.4.21 Rectangles

Rectangles may be filled or unfilled. Unfilled rectangles will use the current pen style for the
border but filled rectangles will always use a solid border.

Example: Drawing a Rectangle

"
Step 1. Click button to select the pen/fill style and color.

Step 2. Click & button from the function toolbars.
Step 3. Move the mouse to the corner of the desired rectangle. Press and hold the left button of
the mouse while dragging the mouse. An outline of the desired rectangle will be

displayed.

Step 4. Release the left button of the mouse to define the rectangle with the selected attributes.
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5.4.22 Polygons

Polygons may be filled or unfilled. Unfilled polygons will use the current pen style for the border
but filled polygons will always use a solid border. You may define up to 32 vertices. After 32
vertices are selected, the polygon will automatically close itself.

Example: Drawing a Complex Polygon
"
Step 1. Click button to select the pen/fill style and color.

Step 2. Click button from the function toolbars.

Step 3. Polygons are specified by their vertices. To specify a vertex move the mouse to the
desired location and click the left mouse button.

Step 4. Starting with the second vertex, edges joining the two last vertices will appear as new
vertices are specified.

Step 5. To complete the polygon with the selected attributes, you can either double click the left
mouse button. This will draw an edge from the last vertex to the first vertex or click the
right mouse button to abort the process.

5.4.23 Place Button

Place Button function creates a button placement(positioning) on the current page and displays
the placement of the button image on the design window. Once a button has been placed on the
page its function and appearance may be defined. The design and development of touch menu
systems is discussed in greater detail in the Define Button section.

When actuated, Place Button invokes a dialog box. Within the dialog box is the rough placement
grid. This grid represents the design window and its cells are possible button locations. The
number of cells is a function of the default button size. Button size is determined by the template
function. Clicking a grid cell places a button of the current default size at a corresponding
location in the design window. (Clicking again at the same location will erase the button.) The
button may be moved or resized later with the edit and move functions. The button placement
dialog box gives access to another dialog box, the template editor. The template, as mentioned
above, is the default button size. It is characterized by the rectangle of the resulting button. The
template editor allows the rectangle to be specified.

The button placement dialog box also displays button resource information. Many Deeco serial
terminals allow only a fixed number of button regions. A button region is defined by position as
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well as shape. Button regions may be used on multiple pages, and always have the same position
and shape.

Example: Create a Button Image with Default Dimensions

Step 1.

Step 2.
Step 3.

Step 4.

Select the New option from File menu.

Click EI button on the function toolbars, the Assign Button Location dialog box appears.
Click one square from the grid located within the Assign Button Location dialog box.

Click the OK button. At this point , the button image will be created on the design
window.

5.4.24 Button Size

Sizing of button, if the default is not sufficient, may be accomplished by editing the button. Click

the k=8 button from function toolbars and then select the button for editing by clicking on it. The
resize handles will appear enabling the button to be re-sized. Move the mouse to one of the resize
handles, click and drag to re-size the button.

Example: Changing the Size of an Existing Button

Step 1.

Step 2.

Step 3.

Step 4.

Step 5.

Select the New option from File menu.

Create a button image on the design window.

Click the button from the function toolbars.

Click the target button with the mouse. The button will be highlighted with blocks at each
corner.

Click and drag one of the corner blocks until the button is of the desired dimension then
release the mouse button.
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5.4.25 The Template

If a new default size is desired, the template defining the default may be changed. The Template
editor is entered through the Template button in the Assign Button Location dialog box. The size
of the default may be defined by creating a box in the work area of the desired size. The box is
drawn by moving the mouse to a convenient point representing the upper left corner, pressing the
left mouse button and dragging the mouse to the lower right corner. The height and width is
shown in pixel size and updated as the box is defined. Release the mouse button when the desired
size is obtained.

Example: Create a Button using Template Dimensioning

Step 1. Select the New option from File menu.

Step 2. Click the EI button from function toolbars, the Assign Button Location dialog box
appears.

| Assign Button Location ||
Page : II:I "I Buttaon Available ;121

Button Size: 32 % 32

Pointing and click |eft mousze button to locate the buttan

T emplate

Step 3. Click the Template button, the Define Button Size dialog box appears.
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Define Button Size I

Prezs left maouze down and drag to define button size

Button Size

Default Size |
Cancel |

Step 4. Move the mouse into the work area to the left of the Button Size window.

Step 5. Click and drag the mouse until you create a button with a width and a height of 80 pixels.
The new button dimensions can be observed in the button size window.

Step 6. Click the OK button to exit the Define Button Size dialog box.
Step 7. Select two adjacent boxes from the grid located in the Assign Button Location window.

Step 8. Click the OK button to exit the Assign Button Location dialog box. The design window
will display two button images with new button size.

5.4.26 Graphic Text

See Graphic Text Attributes for detail.

Example: Drawing Graphical Text

Step 1. Click the button from the function toolbars to select graphic text attributes.

Step 2. Click el button from the function toolbars.
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Step 3. Move the mouse to the start position (lower left) of the desired text string and click the
left mouse button. The Text String dialog box will appear where the ASCII text may be
entered.

Step 4. Enter the following text string: This is an example of the text function.

Step 5. Click the OK button to draw the text in the design window, or click the Cancel button to
abort the operation without displaying any text.

Step 6. You can edit the existing text by pointing and double click the left mouse button.

5.4.27 Bitmap

The Bitmap function allows you to embedded a bitmap within the design window and TOUCH
ASSIST IV can download the bitmap to the serial terminal. You can use third-party utilities (i.e.
Paint Brush, Image Editor) to build the bitmap file. Currently, TOUCH ASSIST IV only support
BMP file format.

5.4.28 Scan Line

Each scan line consists of consecutive bytes which are representing the pixels in the scan line. The
number of bytes representing a scan line depends on the color format and the width, in pixels, of
the bitmap. If necessary, a scan line must be zero-padded to end on a 32-bit boundary (4 bytes).
So this will show the dark pixels in the displaying picture. In order to eliminating this problem,
Jor 256 colors, the size of the width, in pixels, should always sit on the boundary which can be
divided by 4 and divided by 8 for 16 colors. TOUCH ASSIST IV only supports 16 colors and 256
colors bitmap file.

5.4.29 How to embedded a bitmap

Step 1: Click (241 button from the function toolbars, the Open File dialog box appears.
Step 2: Select the bitmap file name.
Step 3: Click the OPEN button to show the bitmap or click the CANCEL button to cancel the

process. The bitmap always show at the left upper corner within the design window.
Drag the bitmap where you want it.

49



Touch Assist IV User Manual

5.4.30 Erase

The Erase function is a modal function that operates on graphic objects and buttons. Objects and
buttons are deleted and cease to be displayed when erased. CAUTION: THERE IS NO UNDO!

To erase an object, select the erase function and move the mouse cursor to the object to be erased.
Clicking the left mouse button will erase the object. Care must be taken when erasing an object
which overlaps or is overlapped by another object. The mouse cursor should be in a non
overlapped region of the desired object before it can be clearly identified. If this is not possible,
such as in the case of completely overlapped objects, it is suggested that the items be moved to
isolate the desired object of erasure.

Example: Erase Function

Step 1. Select the New option from File menu.

Step 2. Create a circle as described in the circle example.

Step 3. Click the button from the function toolbars.

Step 4. Place the mouse pointer within the area of the circle and click the left mouse button. This
will cause the circle to be erased from the design window.

Step 5. Choosing any other function or menu item will deactivate the Erase function.

5.4.31 Refill

When editing a filled graphic object, it is possible to change the fill palette and style in the filled
area.

Example: Refill Function
Step 1. Select the New option from File menu.

Step 2. Create a circle as described in the circle example.

Step 3. Click button from function toolbars, the fill/pen pattern tabbed dialog box appears.

Step 4. Select the new fill style and color, click OK button.

Step 5. Click (& button from the function toolbars.
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Step 6. Place the mouse pointer within the area of the circle and click the left mouse button. This
will cause the circle to be repainted with the new selected fill style from the design
window.

Step 7. Choosing any other function or menu item will deactivate the Refill function.

5.4.32 Fine Move

The Fine Move function can be used to accurately place an graphic object to the pixel level
(button will be placed at the touch level) The object is selected by clicking it. The four arrow keys
of the keyboard may then be used to move the object up, down, left, or right. The cursor moves
with the object and the mouse position reported in the status bar is maintained so the position can
be monitored during the move.

Example: Fine Move Function

Step 1. Select the New option from File menu.

Step 2. Create a rectangle as described in the rectangle example.
Step 3. Click the button from the function toolbars.

Step 4. Place the mouse pointer within the area of the rectangle and click the left mouse button.

Step 5. Click E button from the function toolbars.
Step 6. Use keyboard direction keys (up, down, left, right) to move the rectangle.

Step 7. Choosing any other function or menu item will deactivate the Fine Move function.
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5.5 The Status Bar

[Page @ [M3B40:480 [ %571 v476 |[CAF [NUM [SCRL

The Status Bar displays information about the design window. The mouse position within the
design window which is helpful for precision placement of objects in the design window, the
selected serial terminal, the page number identifying the current page within the design window
and some important keyboard information.

Context sensitive help also appears on the status bar. As functions from the Function Toolbars or
items from the Menu Bar are selected, messages are displayed on the status bar describing
options or required actions to complete or modify the function.

5.6 The Host Response Status Bar

The Host Response Status Bar is used to display the information transmitted from the attached
Deeco serial terminal. While TOUCH ASSIST 1V is in test mode, the host responses of the
activated buttons will also display here.

6.0 Application Development

The application generation process centers around the target terminal of a TOUCH ASSIST IV
design and the creation of touch menus, or pages. The selection of the target terminal implicitly
selects the screen dimension and insures the translation of the TOUCH ASSIST IV design to
proper output format.

A page is a group of buttons collectively displayed on the target terminal screen and referred to by
a single numeric ID, the page number. The page number is selected by the page buttons from the
function toolbars or select the from the menu bar. The contents of the page is displayed in the
design window after page changed.

6.1 Touch Menu Generation

Touch menu, or button page, generation starts with the layout of the buttons on a page. Pages are
referenced by a numerical ID, starting at zero (0). Typical applications start with page one (1)
reserving page 0 for special use (many Deeco serial terminals attach special features to page 0).
Each page contains a different menu and, perhaps, graphic images.
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6.2 Define Button

The place button function will let you place as many button images as the page requires. The
button image only defines the shape, location and the size, it has no button function. The internal
of a button is comprised of one or more states; each state contains a label, a host response, and a
local response. The label is used as the visible text identifier of the button, the host response is a
message sent over the communication link from the host system when the button is actuated, and
the local response is a command sequence replayed internally when the button is actuated. Upon
actuation the button automatically moves to the next state displaying the new label. States may
also be assigned different visual attributes. A button will not be function until the label, host
response and local response are all defined.

6.3  Button Label

To define the label, click in the label edit field in the Button Response dialog box. The text
cursor will allow the entry of a text string which will be the label for the state. Multiple line
labels are defined by delimiting each line with a carriage return generated by the key combination
of SHIFT-6 then SHIFT-M. Labels are automatically centered, left to right and top to bottom.

6.4  Button Host Response

The host response is entered similar to the label. Click on the host edit field in the Button
Response dialog box. Enter the text of the response from the keyboard. Control codes and codes
with the eight bit set may be embedded by using a backslash preceding a pair of ASCII
hexadecimal digits. Control codes may also be included by using * preceding the appropriate
letter. Characters which must be preceded with a backslash include: \:; " | /.
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6.5  Button Attributes

The button attributes only affect the visual appearance of the button. It includes the label
foreground and background color, label orientation, button background filled style and so on.
TOUCH ASSIST IV provides an easy way for you to design your button. You only need to do is
clicking and selection, all the internal complexion works are handled by TOUCH ASSIST IV.

Example: Create a Button with Button Attribute
Step 1. Select the New option from File menu.

Step 2. Create a button image on the design window, move mouse to the button image and double
click the left mouse button, the Button Response dialog box appears.

 Button Response ||
Button State: 0 ill Delete |
Attribute |
Label :

Hoszt Responze

Local Responze :

Buttan Capture

I Button I Graphics [~ Popup Capture |
™ Page [T Dizplay List Edit Popup |

Help |

Step 3. Click Label edit field and enter: One.

Step 4.  Click Host Response edit field and enter: One.
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Step 5. Click the Attribute button, the Button Attribute dialog box appears.

Button Attribute

— Palette
— Fill Pattern Style
Hilit —
zalid fill
wert fill — Colar Abtribnte ——————
i
left zlant hatch fill "'r":r o bl
right =lant hatch il | ‘Ecl?":':m !
zparze dot fill Ia Bl e
wide left shart fil abel text background
wide right slant fil E:!te E“'der .
diaganal fill it ackaground fill
cross fill hlite label test
hlite label text backgraund
— Label
Tewt zize IEI vI
Textangle: [ 90 Degres Cancel |
CharSet: T User Defined

Step 6.

Step 7.

Step 8.

Step 9.

Step 10. Click OK button to exit the Button Response dialog box.

Using the Color Palette buttons and click the item within Color Attribute list box to set
button colors, text label color and so on. The demo style box will reflect all the changes
of current button attributes.

Select the Vertical fill within the Fill Pattern list box to set button background fill style.

Click the Hilite box then select the Cross fill under the Fill Pattern list box, the Cross fill
pattern will be used to fill the button background when it has been actuated.

Click OK button to exit the Button Attribute dialog box.

Step 11. Select the Test option from Touch menu.
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Step 12. Click button image to see the button attributes changed and the host response message
One will be displayed on the Host Response Status Bar.

Step 13. Select the Test option from Touch menu to exit the test mode.

6.6  Button Local Response

A local response is a sequence of Deeco serial terminal compatible commands which are replayed
through the serial terminal's command parser as if the commands had come from the hasy
command which can be sent from the host is possible to embed in a local response. The local
response may be entered in the same fashion as the label or host message. To embed complex
command sequences, TOUCH ASSIST IV has provided five button capture options.

6.7  Capture Button

Capture Button embeds a command in the local response which couples the current button to
another button, perhaps on another page. When the current button is pressed in the target
terminal, the coupled button will also appear to be pressed. This has the effect of changing the
coupled button's state. In the test mode, if the coupled button is on the current page, its label
will be updated and the host message will be sent but its local response will not be executed.
Example: Creating a Button with Capture Button

Step 1. Select the New option from File menu.

Step 2. Create two button images on the design window, move mouse to the first button image
and double click the left mouse button, the Button Response dialog box appears.

Step 3. Click Label edit field and enter: One.
Step 4. Click Host Response edit field and enter: One.
Step 5. Click the Button option box from Button Capture.

Step 6. Click the Capture button, the Exit Button Capture dialog box appears.
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Step 7.

Step 8.

Step 9.

Step 10.
Step 11.
Step 12.
Step 13.

Step 14.

Step 15.

6.8

Capture

Exit Button Capture
Choose " 0K after
capture button

Moving the mouse to the second button image and click the left mouse button to end the
selection. Click the OK button to exit the Exit Button Capture dialog box, the Button
Response dialog box reappears. The command for the captured button are automatically
entered into the local response edit field.

Click the OK button to exit the Button Response dialog box.

Move mouse to the second button image and double click the left mouse button, the
Button Response dialog box appears.

Click Label edit field and enter: Two.

Click Host Response edit field and enter: Two.

Click OK button to exit the Button Response dialog box.
Select the Test option from Touch menu.

Click first button and the host response message One and Two will both be displayed on
the Host Response Status Bar.

Select the Test option from Touch menu to exit the test mode.

Capture Page

Page allows you to couple the current button to another page of buttons. When the

current button is pressed in the target terminal, this will cause the current button page to be erased
and the new page to appear.

Example: Create a Button with Capture Page

Step 1.

Step 2.

Select the New option from File menu.

Create a button image on the design window, move mouse to the button image and
double click the left mouse button, the Button Response dialog box appears.

57



Touch Assist IV User Manual

Step 3. Click Label edit field and enter: One.

Step 4. Click Host Response edit field and enter: One.

Step 5. Select the Page option box from Button Capture.

Step 6. Click the Capture button , the Page Number dialog box appears.

Step 7. Enter a value of 1 then click the OK button. Any value from 0 to 119 can be selected. The
change page command is automatically entered into the local response edit field.

Step 8. Click the OK button to exit the Button Response dialog box.
Step 9. Select the Test option from Touch menu.

Step 10. Click the button with the left mouse button, the design window will change to the page 1
and the page number in the Status Bar will display the page number 1.

Step 11. Select the Test option from Touch menu to exit the test mode.

6.9 Capture Graphics

Capture Graphics embeds a sequence of graphic commands in the local response of the button. We
recommend that display lists be used to call up graphics. If the serial terminal unit does not
possess an auxiliary memory, you can embed graphics within button response.

Example: Create a Button with Capture Graphics

Step 1. Select the New option from File menu.

Step 2. Create a button image on the design window, move mouse to the button image and double
click the left mouse button, the Button Response dialog box appears.

Step 3. Click Label edit field and enter: One.
Step 4. Click Host Response edit field and enter: One.
Step 5. Select the Graphics option box from Button Capture.

Step 6. Click the Capture button, the Exit Button Capture dialog box appears.
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Step 7.

Step 8.
Step 9.
Step 10.
Step 11.
6.10

Capture

Chooze " 0K after
define all graphic(z]

Define circle as example and click the OK button. The Button Response dialog box
reappears. The command for the defined circle is automatically entered into the local
response edit field.

Click the OK button to exit the Button Response dialog box.

Select the Test option from Touch menu.

Click the button with the mouse, the design window will display the defined circle.
Select the Test option from Touch menu to exit the test mode.

Capture Display List

Display List embeds a display list into the local response of the button. The display list is

specified by its numeric ID. These options cover most response requirements. Except for the Pop-
up option, all options may be embedded in the same response. If the Pop-up button is chosen no
other captures can be selected.

Example: Create a Button with Capture Display List

Step 1.

Step 2.

Step 3.

Step 4.
Step 5.
Step 6.

Step 7.

Select the New option from File menu.

Follow steps 1-6 from the example of Define List to assign a file associated with a
display list number.

Create a button image on the design window, move mouse to the button image and double
click the left mouse button, the Button Response dialog box appears.

Click Label edit field and enter: One.

Click Host Response edit field and enter: One.

Select the Display List option box from Button Capture.

Click the Capture button, the Define Display List dialog box appears.
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Define Display List I
|nput Dizplay Lizt Mumber ; ||
0k I Cancel |

Step 8. Enter the display list number which you select in step 2 then click the OK button. The
execution of display list command for the selected display list number is automatically
entered into the local response edit field.

Step 9. Click the OK button to exit the Button Response dialog box.
Step 10. Select the Test option from Touch menu.

Step 11. Click the button image with the left mouse button, the contents of the file which
associated with the display list number will be executed and displayed in the design
window.

Step 12. Select the Test option from Touch menu to exit the test mode.

6.11 Capture Pop-Up Menu

Pop-up menus are touch elements which mimic the Windows style pull down menus. Capture
Pop-up embeds the necessary commands to initiate a Pop-up. The Pop-up itself is defined by a
user selected page number and a sequence of pop-up elements (the items of the pop-up). To
conserve memory and avoid terminal operational difficulties; ALWAYS SELECT THE LOWEST
UNUSED PAGE TO DISPLAY THE POP-UP MENU. Sece examples section for a more detailed
explanation. Capture will invoke a dialog box to specify the page number and then a dialog box to
define the pop-up elements.

A pop-up item is added to the list of items by entering the text of the item as it will appear on the
target screen and clicking the Add button. You can use the Delete button to erase a menu item, the
Change button to rename a menu item, and the Insert button to change the order of the menu
items. The host message and local response of each pop-up item are specified in an abbreviated
response dialog box entered by double clicking an item. The procedure of defining the pop-up
response is similar to the button response without the label field edit feature.
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Example: Create a Button with Capture Popup Menu

Step 1.

Step 2.

Step 3.
Step 4.
Step 5.

Step 6.

Step 7.

Select the New option from File menu.

Create a button image on the design window, move mouse to the button image and double
click the left mouse button, the Button Response dialog box appears.

Click Label edit field and enter: One.
Click Host Response edit field and enter: One.
Select the Pop-up box from the Button Capture.

Click the Capture button, the Assign Popup Page dialog box appears.

Page Mumber : |1|
Cancel |

Enter a value of 1 for the Page Number and click the OK button. The Create Popup
Menu dialog box appears.
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Create Popup Menu I

Popup Menu ltem : I

| Fointing and double clck left mouse button to define menu ikem |

b enu Position

o

o ||:|_ 1%
Add |
Delete |

Change | Help
|

|nzert ak.

Step 8.  Click the Popup Menu Item edit field and enter the word: Popupl. Click the Add
button, the text Popupl will appear inside the list box.

Step 9.  Click the Popup Menu Item edit field and enter the word: Popup2. Click the Add
button, the text Popup2 will appear inside the list box.

Step 10. Select the x edit field under Menu Position and enter a value of 0.

Step 11. Select the y edit field under Menu Position and enter a value of 0. The default position
(0,0) will show the popup menu at the upper right corner of the button.

Step 12. Double click the word Popupl within the list box. The Popup Menu Response dialog
box appears.
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Popup Menu Rezponze I

tenu ltem Label ;100

’_@_‘ Host Responze
=] ||

Local Response
; I Caphure |
Capture

I Button [~ Page ™ Graphicz [ Display List

Step 13. Click Host Response edit field and enter: Popupl, click the OK button.
Step 14. Double click the word Popup2 within the list box.
Step 15. Click Host Response edit field and enter: Popup?2, click the OK button.

Step 16. Click the OK button within the Create Popup Menu dialog box. The Button Response
dialog box reappears.

Step 17. Click the OK button to exit the Button Response dialog box.
Step 18. Select the Test option from Touch menu.

Step 19. Click the button with the mouse. At this time, the design window will show a popup
window with the defined menu.

Step 20. Select the Test option from Touch menu to exit the test mode.
Example: Edit a Button with Capture Popup Menu

Step 1. Create a button as described in the example of creating a button with capture popup
menu.

Step 2. Moving mouse to the button image and double click the left mouse button, the Button
Response dialog box appears.

Step 3. Click the EditPop button, the Create Popup Menu dialog box appears.
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Step 4.

Step 5.

Step 6.

Step 7.

6.12

Select the menu item inside the list box, the menu item text will show in the Popup Menu
Item edit field.

You can edit the text and click the Change button to change the item name, click the
Delete button to erase the menu item or click the Insert button first then select a new
position within the list box to put the text in the new position.

Click OK button to exit the Create Popup Menu dialog box.

Click OK button to exit the Button Response dialog box.

Button with Multistates

Button responses can be programmed in such way that each successive touch will send a different
host message and local response from a list of sequential states. In addition, each state may relabel
the button if desired, or change the button attributes. Up to 16 states may be defined for any
button. The button will initially be labeled with the label specified by state 0. When it is actuated,
the host and local responses will be those of state 0. The button then will be relabeled with the
next state’s label and all the new attributes. When the final state is actuated, the state will return to

0.

Example: Create a Multistates Button with Different Attributes

Step 1.
Step 2.

Step 3.

Step 4.
Step 5.
Step 6.
Step 7.
Step 8.
Step 9.

Step 10.

Select the New option from File menu.
Create a button image on the design window.

Double click the left mouse button on the button image, the Button Response dialog box
appears.

Click the A#tribute button to set the button attribute.
Click Label edit field and enter: One.

Click Host Response edit field and enter: One.
Select the Graphic box from Button Capture.

Click the Capture button.

Create a circle on the design window.

Click the OK button to exit the Exit Button Capture dialog box.
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Step 11.

Step 12.
Step 13.
Step 14.
Step 15.
Step 16.
Step 17.
Step 18.
Step 19.
Step 20.
Step 21.

Step 22.

Step 23.

Step 24.

Step 25.
Step 26.

Step 27.

Step 28.
Step 29.

Step 30.

Click the Down Arrow button at the Button State Spin Button. Note that the button state
has changed from O to 1 and all labels and responses have been cleared.

Click the A#tribute button to set the button attribute.

Click Label edit field and enter: Two

Click Host Response edit field and enter: Two

Select the Popup box from Button Capture.

Click the Capture button.

Enter a value of 1 for the Assign Popup Page and click the OK button.

Select the Popup Menu Item and enter the word: Popupl. Click the Add button.
Select the Popup Menu Item and enter the word: Popup2. Click the Add button.
Select the x edit field under the Menu Position and enter a value of 0.

Select the y edit field under the Menu Position and enter a value of 0.

Double click the word Popupl within the list box, the Popup Menu Response dialog box
appears.

Click Host Response and enter: Popupl and click the OK button.

Double click the word Popup2 within the list box, the Popup Menu Response dialog
box appears.

Click Host Response and enter: Popup2 and click the OK button.
Click the OK button to exit the Create Popup Menu dialog box.

Click the Down Arrow button at the Button State Spin Button. Note that the button state
has changed from 1 to 2 and all labels and responses have been cleared.

Click the Attribute button to set the button attribute.
Click Label edit field and enter: Three.
Click Host Response edit field and enter: Three.
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Step 31.

Step 32

Step 33.
Step 34.
Step 35.
Step 36.
Step 37.
Step 38.
Step 39.
Step 40.
Step 41.
Step 42.

Step 43.

Select the Page box from the Button Capture.

. Click the Capture button, he Page Number dialog box appears.

Enter a value of 4 for the Page Number and click the OK button.
Click the OK button to exit the Button Response dialog box.

Using GoTo option from Page menu to change current page to page 4.
Create a button image on the design window at page 4.

Double click the left mouse button on the button image.

Click Label edit field and enter: Return

Select the Page box from Button Capture.

Click the Capture button, the Page Number dialog box appears.

Enter a value of 0 and click the OK button.

Click the OK button to exit the Button Response dialog box.

To test the buttons, select Test option from Touch menu and click the button with the
mouse.
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7.0 Online Help

TOUCH ASSIST IV provides Online Help to assist you in designing the application. You can use
the following ways to obtain Help.

(1) Press the FI key to view a list of Help topics .

(2) When you are using a dialog box that has a Help button, click the dialog button to display
information about working with the dialog box.

(3) Choose the Help menu to display a list of Help commands.

7.1  Technical Support

Deeco offers a variety of support options to help you get the most from Touch Assist IV. Before
contacting the technical support, please try to resolve your problems by referring to this manual
and the serial terminal manual.

E-mail

You can ask questions and receive detail answers from the Technical Support via CompuServe.
Just send e-mail to the following account.

From CompuServe account: LDTECHSUPPORT@COMPUSERVE.COM

Internet

Visit our web site at http://www.deeco.com

Fax

You can fax the questions or comments. Address the fax to "Technical Support”. The fax number

is:
510-489-3500

Telephone

You can reach the Technical Support by phone between 8:00 A.M. and 5:00 P.M.; Monday
through Friday with phone number: 510-471-4700
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Bulletin Board Service

You can use the service to download samples and submit files. The protocol is 9600 baud, 8§ data
bits, 1 stop bit, no parity

BBS phone number: 510-471-5402
Mail
You can send your mail to the following address.

Lucas Control Systems, Deeco
31047 Genstar Road
Hayward, California U.S.A. 94544-7831

8.0 Application Integration

Once the application has been found to meet certain minimum functionality goals, it may be
incorporated into the host system. The menus, graphics, and display lists resulting from the
design may be included in the software of the host, or if the application has been carefully
designed to make full use of display lists, it may be downloaded into the non-volatile memory
option of the target terminal. Regardless of where the application physically resides, it must be
invoked at system initialization. System initialization is typically a power-up of all system
components. If the application information is resident in the host, it may be downloaded from the
host to the target at the host's convenience. If the application is pre-loaded into the target's non-
volatile memory in the form of a display list, the unit can be configured to automatically invoke
the lists and self-initialize.

Most Deeco serial terminals which offer display lists also offer the ability to automatically execute
a list upon power-up. This auto-configure feature is usually accessible from the set-up function of
the target terminal. List ID 0 is usually reserved for auto-configure. If an application is
structured so that it is partitioned into lists, and list 0 is dedicated to controlling an initialization
then the application may be embedded within the non-volatile memory option of the Deeco serial
terminals and auto-configure may be used to invoke the application.

Two other means of generating a usable form of a TOUCH ASSIST IV design exist. The Queput
menu allows a TOUCH ASSIST IV design to be translated into a command stream and placed in a
file. The file can be unformatted and used at run-time as input to a host software system and
downloaded to the target device.
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9.0 Index

A

alpha control, 36

append file, 10

application development, 52
application integration, 68
arcs, 37, 43

arrange list, 21

ASCII, 9, 21, 27, 49

ASM file, 27

B

bit operation, 33

bitmap, 49

button attribute, 54
button capture, 56

button host response, 53
button label, 53

button local response, 56
button page, 52

button response, 20, 53

C

C file, 28

capture button, 56
capture display list, 59
capture graphics, 58
capture page, 57
capture popup menu, 60
circle, 31, 32, 37, 43, 44, 50, 51
communication, 24
complex polygon, 45
Config, 22

copy, 11, 31, 32

create font file, 34
creating a file, 7

cut, 11, 30, 31
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D

define button, 53

define list, 19

delete file, 10

delete list, 20

design window, 5, 6, 35, 43, 45, 46, 49, 50, 51, 52
display list, 10, 18, 19, 20, 59, 68

download, 27

download setting, 26

E

edit, 11, 30, 40, 45, 46, 53, 60
edit and move, 40

erase, 45, 50

exit button capture, 57

exit Touch Assist IV, 11

F

file, 7

fine move, 51

font editor, 32

function palette, 5

function toolbar, 5, 30, 31, 32, 37, 40, 41, 50, 52

G

goto, 17

graph palette, 37
grid lines, 35
group move, 42

H

help, 6, 29, 52

help contents, 30

help topics, 29

host, 18, 35, 53, 56, 60, 63, 68
host response, 53

host response status bar, 5, 52
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installation, 1

L

local response, 53

M

menu bar, 5, 6, 52
multistate button, 64

N

new, 31
new file, 7

O

online help, 67
open, 31
open file, 8
options, 14
output file, 24

P

page, 16, 52

page change, 18
page control, 36
page number, 52
page summary, 17
paste, 11, 30, 31, 32
place button, 53
polygon, 37, 45
popup menu item, 62, 65
port setting, 24

print all, 15

print page, 15
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R

rectangle, 44
refill, 50
reset, 22
resize, 40

S

save, 31

save file, 8

saveas file, 9

scan line, 49

screen color, 35
select all, 12

send command to, 28
send text file to, 29
settings, 25

single move, 41
status bar, 5, 12, 51, 52
summary, 17

T

template, 45, 47

test all, 16

test mode, 16, 35, 36

text, 19, 30, 39, 48, 49, 53, 60
title bar, 5

toolbar, 12

touch, 13

touch menu generation, 52
touch module, 22

Vv

vectors, 37, 43
view, 12

view file, 9
view list, 20
view page, 13
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w

work area, 33
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